Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

IE11 broken on 7.13.x #2827

Closed
thesandlord opened this issue Mar 29, 2020 · 1 comment
Closed

IE11 broken on 7.13.x #2827

thesandlord opened this issue Mar 29, 2020 · 1 comment
Assignees

Comments

@thesandlord
Copy link

@thesandlord thesandlord commented Mar 29, 2020

[REQUIRED] Describe your environment

  • Operating System version: Windows 10
  • Browser version: IE11
  • Firebase SDK version: 7.13.1
  • Firebase Product: Firestore

[REQUIRED] Describe the problem

Firestore (both memory-only and standard versions) breaks on IE11 with version 7.13.0 and 7.13.1

Everything works fine on 7.12.0

The first error is:

SCRIPT5009: 'crypto' is undefined

Which is easy to fix with a pollyfill
var crypto = window.crypto || window.msCrypto;

After that, this error pops up:
SCRIPT438: Object doesn't support property or method 'forEach'

I think this is caused by this PR:
#2764

Specifically this line:

This is a Uint8Array, so it needs to be pollyfilled like this:
Uint8Array.prototype.forEach = Array.prototype.forEach;

I don't think these pollyfills are included in @babel/preset-env or the core-js all in one script

@schmidt-sebastian
Copy link
Contributor

@schmidt-sebastian schmidt-sebastian commented Mar 31, 2020

This will be fixed in the next release.

@firebase firebase locked and limited conversation to collaborators May 1, 2020
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
Development

No branches or pull requests

4 participants