Permalink
Browse files

debian packaging: bump version to debhelper compat level 9

  • Loading branch information...
1 parent 6c3f12f commit fcd53af89dcb808e1c9ee64243c2af71c6ab5282 @zanchey zanchey committed Jan 7, 2017
Showing with 4 additions and 8 deletions.
  1. +1 −1 debian/compat
  2. +1 −1 debian/control
  3. +2 −6 debian/rules
View
@@ -1 +1 @@
-8
+9
View
@@ -3,7 +3,7 @@ Section: shells
Priority: extra
Maintainer: ridiculous_fish <corydoras@ridiculousfish.com>
Uploaders: David Adam <zanchey@ucc.gu.uwa.edu.au>
-Build-Depends: debhelper (>= 8.0.0), libncurses5-dev, autoconf, autotools-dev, dh-autoreconf, gettext
+Build-Depends: debhelper (>= 9.0.0), libncurses5-dev, autoconf, autotools-dev, dh-autoreconf, gettext
# When libpcre2-dev is available on all supported Debian versions, add a dependency on that.
Standards-Version: 3.9.4
Homepage: http://fishshell.com/
View
@@ -4,18 +4,14 @@
# Uncomment this to turn on verbose mode.
export DH_VERBOSE=1
-# dpkg-dev 1.16.1 doesn't export buildflags
-# can be removed once on dh compat level 9
-DPKG_EXPORT_BUILDFLAGS = 1
--include /usr/share/dpkg/buildflags.mk
-DEB_DISTRIBUTION = $(shell dpkg-parsechangelog | sed -n -e 's/^Distribution: //p')
-
%:
dh $@ --with autotools-dev,autoreconf
override_dh_installdocs:
dh_installdocs --link-doc=fish
+# Still needed until all platforms have debhelper 9.20151219
+# Consider transitioning https://wiki.debian.org/DebugPackage
override_dh_strip:
dh_strip --dbg-package=fish-dbg

0 comments on commit fcd53af

Please sign in to comment.