Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

babel-plugin-macros broken: "The 'decorators' plugin requires a 'decoratorsBeforeExport' option, whose value must be a boolean." #345

Closed
sw-yx opened this issue Sep 26, 2018 · 4 comments

Comments

@sw-yx
Copy link

@sw-yx sw-yx commented Sep 26, 2018

something broke recently... just fire up a fresh astexplorer and select the babel-plugin-macros transform:

https://astexplorer.net/#/gist/5487bdb859dd3fd3940134af938f7d4b/3c0ba3060bf92a07af103c7203e42aa29034dc01

which errors out of the box

image

which is probably related to your recent commit, which i am not sure is deployed: e931c05

@sw-yx

This comment has been minimized.

Copy link
Author

@sw-yx sw-yx commented Sep 26, 2018

@skevy's commit as well 9dab028

@fkling

This comment has been minimized.

Copy link
Owner

@fkling fkling commented Sep 26, 2018

Yep, it was deployed to https://latest.astexplorer.net, but not https://astexplorer.net yet. I'll do that as soon as possible. See

https://t.co/2JHMDE6eZ1 has a fix for babel-plugin-macros. Please use that until I deployed it to stable. I'll be back in about a week.

— Felix Kling (@fkling42) September 14, 2018
@sw-yx

This comment has been minimized.

Copy link
Author

@sw-yx sw-yx commented Sep 26, 2018

ah. thanks felix. you are super freaking awesome, didnt expect a response so soon! closing for now

@sw-yx sw-yx closed this Sep 26, 2018
@fkling

This comment has been minimized.

Copy link
Owner

@fkling fkling commented Sep 27, 2018

Published!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.