Add UI to configure SMTP settings #258

Closed
tobscure opened this Issue Aug 27, 2015 · 21 comments

Projects

None yet
@tobscure
Member

What needs to be done:

  • Create an AdvancedPage in the admin CP and add a link for it in the AdminNav. (Related: #167)
  • Add fields to allow SMTP config to be saved. Use BasicsPage as an example.
@tobscure tobscure referenced this issue Aug 28, 2015
Open

v0.1.0 roadmap #74

19 of 53 tasks complete
@justjavac justjavac referenced this issue in justjavac/Flarum Sep 7, 2015
Open

Flarum v0.1.0 开发路线图 #3

10 of 53 tasks complete
@ethnp
ethnp commented Nov 5, 2015

How do I setup the email configuration settings? The fields are blobs...

@Zoink5
Zoink5 commented Dec 6, 2015

The fields are blobs as mentioned by @ethnp - I tried editing them directly but this broke my setup.

@pescu25
pescu25 commented Jan 16, 2016

yes,how?

@riznmage

@wa-Nadoo The fields are blob, and can not be edited?

Fresh install from composer today.

@riznmage

@wa-Nadoo Well, I'm getting this error: #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'INSERT INTO config(key, value)...

@kerlw
kerlw commented Jan 24, 2016

@riznmage table 'config' has been renamed to 'settings'(Of course, you need to add your prefix.)

@Luceos
Member
Luceos commented Jan 24, 2016

Please use this issue to discuss the implementation of the UI for configuring the SMTP settings. For questions how to do it without this implementation, use the forums! Or use an SMTP extension from the list.

@franzliedke franzliedke modified the milestone: 0.1.0 Apr 7, 2016
@datitisev
Contributor

Ok, so I'm trying to make this 😉
Should it be found (the SMTP settings) in the Basics page?
Thanks!

@datitisev
Contributor
datitisev commented Apr 16, 2016 edited

How does datitisev/core#258-smpt-settings-ui look?
The only thing missing would be the locale in flarum/flarum-ext-english
I've tested it, and it works fine; aka it puts the data in the database correctly.
Here is a screenshot:

Flarum Admin: Advanced Page w/ SMPT Settings


EDIT: Sorry about the 4 commits instead of 1 😞
EDIT 2: I just noticed that you want this in an "Advanced" page. Sorry I didn't do that, but at least there are settings now 😉
EDIT 3: Updated repo to include new "Advanced" page 😃 & Updated screenshot

@franzliedke franzliedke modified the milestone: 0.1.0-beta.6, 0.1.0 Apr 17, 2016
@datitisev datitisev pushed a commit to datitisev/core that referenced this issue Apr 17, 2016
David Sevilla Mart��n Added "Advanced" page on admin & SMTP settings
Refs #258
45045a2
@franzliedke franzliedke closed this in #933 May 12, 2016
@franzliedke franzliedke added a commit that referenced this issue May 12, 2016
@franzliedke franzliedke Merge branch 'pr/933'
Closes #258.
dd0dc44
@franzliedke franzliedke added a commit that referenced this issue May 15, 2016
@franzliedke franzliedke Tweak structure of mail settings page
Refs #258 and #933.
a884a35
@vivex
vivex commented Sep 27, 2016

do it supports php mail ?

@franzliedke
Member

Hi @vivex, yes, it is possible to configure Flarum to use mail instead of SMTP, however at the moment this is not possible through the user interface. You would have to create a custom extension.

@vivex
vivex commented Sep 27, 2016

@franzliedke thanks for quick reply, So if i change mail_drive in DB to mail , will it work ?

@franzliedke
Member

You could try that, yes - but I'm not sure what that will do to the admin interface, to be honest. ;)

@Luceos
Member
Luceos commented Sep 28, 2016

Yes you can set mail.driver in the database to mail, you can fill in bogus information in the other fields, it will be ignored (if I'm not mistaken).

@tisuchi
tisuchi commented Nov 19, 2016

I am using mailgun, but have issue. None of the email is triggering. My configuration is like follows-

mail_driver : mailgun
mail_from : donotreplay-------------.com
mail_host: smtp.mailgun.org
mail_port : 587
mail_username : postmaster@----------.com
mail_password : *************
mail_encryption: null

Can anybody help me?

@datitisev
Contributor
datitisev commented Nov 19, 2016 edited

@tisuchi This isn't the proper place to discuss this. All the SMTP UI does is set the values into the database. Either your configuration is wrong, or you haven't triggered any events that would send an email.
Please create a discussion at https://discuss.flarum.org for further help.

@Luceos
Member
Luceos commented Nov 21, 2016

@tisuchi you're missing encryption, for 587 it should be tls.

@tisuchi
tisuchi commented Nov 22, 2016

@Luceos

Thanks for you replay. But its not working with encryption too.

@Luceos
Member
Luceos commented Nov 22, 2016

@tisuchi please open a thread on the forums under support so we can track this down more easily.

@franzliedke franzliedke locked and limited conversation to collaborators Nov 22, 2016
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.