blacksmith 1.x doesn't work out of the box on debian #87

Open
przemoc opened this Issue Mar 10, 2013 · 0 comments

Comments

Projects
None yet
1 participant

przemoc commented Mar 10, 2013

System info:

przemoc@debian:~$ uname -a
Linux debian 3.2.0-4-amd64 #1 SMP Debian 3.2.35-2 x86_64 GNU/Linux

przemoc@debian:~$ lsb_release -drc
Description:    Debian GNU/Linux 7.0 (wheezy)
Release:    7.0
Codename:   wheezy

przemoc@debian:~$ nodejs --version
v0.6.19

Packages-related info:

przemoc@debian:~$ dpkg -l 'node*'
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
+++-==============-============-============-=================================
ii  node-abbrev    1.0.3-1      all          Like ruby abbrev module, but for 
ii  node-block-str 0.0.5-1      all          Stream of fixed-size blocks, with
ii  node-fstream   0.1.13-1     all          Advanced filesystem streaming too
ii  node-graceful- 1.1.8-1      all          fs module for Node.js with suppor
ii  node-inherits  0.1-1        all          Helper function to do classic inh
ii  node-ini       1.0.2-1      all          ini format parser and serializer 
ii  node-lru-cache 1.0.5-1      all          Javascript least-recently-used ca
ii  node-minimatch 0.2.0-1      all          Convert glob expressions into Jav
ii  node-mkdirp    0.3.1-2      all          Node.js module to recursively cre
ii  node-node-uuid 1.3.3-1      all          simple, fast generation of RFC412
ii  node-nopt      1.0.10-2     all          Command-line option parser for No
ii  node-request   2.9.153-1    all          simplified HTTP request client fo
ii  node-rimraf    2.0.1-1      all          Deep deletion (like rm -rf) modul
ii  node-semver    1.0.13-2     all          Semantic versioner for NodeJS
ii  node-tar       0.1.13-1     all          read and write portable tar archi
ii  node-which     1.0.5-1      all          Cross-platform 'which' module for
ii  nodejs         0.6.19~dfsg1 amd64        Node.js event-based server-side j
ii  nodejs-dev     0.6.19~dfsg1 amd64        Development files for Node.js

przemoc@debian:~$ dpkg -l 'npm*'
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
+++-==============-============-============-=================================
ii  npm            1.1.4~dfsg-2 all          package manager for Node.js

blacksmith 1.x installation:

root@debian:~# npm install blacksmith -g
npm http GET https://registry.npmjs.org/blacksmith
npm http 304 https://registry.npmjs.org/blacksmith
npm http GET https://registry.npmjs.org/flatiron/0.3.0
npm http GET https://registry.npmjs.org/highlight.js/7.3.0
npm http GET https://registry.npmjs.org/marked
npm http GET https://registry.npmjs.org/mkdirp
npm http GET https://registry.npmjs.org/timespan
npm http GET https://registry.npmjs.org/plates
npm http GET https://registry.npmjs.org/async
npm http 304 https://registry.npmjs.org/flatiron/0.3.0
npm http 304 https://registry.npmjs.org/highlight.js/7.3.0
npm http 304 https://registry.npmjs.org/mkdirp
npm http 304 https://registry.npmjs.org/timespan
npm http 304 https://registry.npmjs.org/marked
npm http 304 https://registry.npmjs.org/plates
npm http 304 https://registry.npmjs.org/async
npm http GET https://registry.npmjs.org/broadway/0.2.5
npm http GET https://registry.npmjs.org/optimist/0.3.4
npm http GET https://registry.npmjs.org/prompt/0.2.8
npm http GET https://registry.npmjs.org/director/1.1.6
npm http GET https://registry.npmjs.org/pkginfo/0.2.3
npm http 304 https://registry.npmjs.org/optimist/0.3.4
npm http 304 https://registry.npmjs.org/director/1.1.6
npm http 304 https://registry.npmjs.org/pkginfo/0.2.3
npm http 304 https://registry.npmjs.org/broadway/0.2.5
npm http 304 https://registry.npmjs.org/prompt/0.2.8
npm http GET https://registry.npmjs.org/wordwrap
npm http GET https://registry.npmjs.org/read
npm http GET https://registry.npmjs.org/revalidator
npm http GET https://registry.npmjs.org/utile
npm http GET https://registry.npmjs.org/winston
npm http GET https://registry.npmjs.org/cliff/0.1.8
npm http GET https://registry.npmjs.org/winston/0.6.2
npm http GET https://registry.npmjs.org/eventemitter2/0.4.9
npm http GET https://registry.npmjs.org/nconf/0.6.4
npm http GET https://registry.npmjs.org/utile/0.1.2
npm http 304 https://registry.npmjs.org/revalidator
npm http 304 https://registry.npmjs.org/wordwrap
npm http GET https://registry.npmjs.org/revalidator/-/revalidator-0.1.5.tgz
npm http 304 https://registry.npmjs.org/utile
npm http 304 https://registry.npmjs.org/read
npm ERR! error installing prompt@0.2.8
npm http GET https://registry.npmjs.org/utile/-/utile-0.1.7.tgz
npm ERR! error installing flatiron@0.3.0
npm http 304 https://registry.npmjs.org/cliff/0.1.8
npm ERR! error installing blacksmith@1.1.3
npm http 304 https://registry.npmjs.org/eventemitter2/0.4.9

npm ERR! Error: No compatible version found: read@'>=1.0.0- <1.1.0-'
npm ERR! Valid install targets:
npm ERR! ["0.0.1","0.0.2","0.0.3","0.1.0","0.1.1"]
npm ERR!     at installTargetsError (/usr/share/npm/lib/cache.js:488:10)
npm ERR!     at next_ (/usr/share/npm/lib/cache.js:438:17)
npm ERR!     at next (/usr/share/npm/lib/cache.js:415:44)
npm ERR!     at /usr/share/npm/lib/cache.js:408:5
npm ERR!     at saved (/usr/share/npm/lib/utils/npm-registry-client/get.js:147:7)
npm ERR!     at Object.oncomplete (/usr/lib/nodejs/graceful-fs.js:230:7)
npm ERR! You may report this log at:
npm ERR!     <http://bugs.debian.org/npm>
npm ERR! or use
npm ERR!     reportbug --attach /root/npm-debug.log npm
npm ERR! 
npm ERR! System Linux 3.2.0-4-amd64
npm ERR! command "/usr/bin/nodejs" "/usr/bin/npm" "install" "blacksmith" "-g"
npm ERR! cwd /root
npm ERR! node -v v0.6.19
npm ERR! npm -v 1.1.4
npm ERR! message No compatible version found: read@'>=1.0.0- <1.1.0-'
npm ERR! message Valid install targets:
npm ERR! message ["0.0.1","0.0.2","0.0.3","0.1.0","0.1.1"]
npm http 304 https://registry.npmjs.org/nconf/0.6.4
npm http GET https://registry.npmjs.org/nconf/-/nconf-0.6.4.tgz
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /root/npm-debug.log
npm not ok

Apparently I am luckless when it comes to giving blacksmith a try... (previous attempt)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment