Permalink
Browse files

Mocha should not load bits of the test-unit gem by accident.

This is an attempt at a fix for the problem that James Adam reported [1]. By using 'load' instead of 'require' to detect the version of Test::Unit, it seems like we can avoid rubygems trying to load bits of the test-unit gem when it's not wanted.

[1] http://floehopper.lighthouseapp.com/projects/22289-mocha/tickets/50#ticket-50-13
  • Loading branch information...
floehopper committed Jun 5, 2010
1 parent ff109bb commit 22599b8bbc99f72b8c33f76df479591a129b3798
Showing with 1 addition and 1 deletion.
  1. +1 −1 lib/mocha/integration/test_unit.rb
@@ -18,7 +18,7 @@ class TestCase
remove_method :run

test_unit_version = begin
require 'test/unit/version'
load 'test/unit/version.rb'
Test::Unit::VERSION
rescue LoadError
'1.x'

0 comments on commit 22599b8

Please sign in to comment.