Skip to content
This repository

Gemspec is invalid #38

Closed
rogerbraun opened this Issue · 6 comments

3 participants

Roger Braun Florian R. Hanke Niko Dittmann
Roger Braun

I am running 1.9.2 with RVM, RubyGems is updated to 1.8.11 and I get the errors below when installing Picky. It seems to be a problem with Syck requiring "=" to be escaped, see igrigorik/em-websocket#65


WARNING:  #<ArgumentError: Illformed requirement ["#<Syck::DefaultKey:0x1f33b84> 3.3.2"]>
# -*- encoding: utf-8 -*-

Gem::Specification.new do |s|
  s.name = "picky"
  s.version = "3.3.2"

  s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
  s.authors = ["Florian Hanke"]
  s.date = "2011-11-02"
  s.description = "Fast Ruby semantic text search engine with comfortable single field interface."
  s.email = "florian.hanke+picky@gmail.com"
  s.executables = ["picky"]
  s.extensions = ["lib/picky/ext/ruby19/extconf.rb"]
  s.files = ["bin/picky", "lib/picky/ext/ruby19/extconf.rb"]
  s.homepage = "http://florianhanke.com/picky"
  s.require_paths = ["lib"]
  s.rubyforge_project = "http://rubyforge.org/projects/picky"
  s.rubygems_version = "1.8.11"
  s.summary = "Picky: Semantic Search Engine. Clever Interface. Good Tools."

  if s.respond_to? :specification_version then
    s.specification_version = 3

    if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
      s.add_development_dependency(%q<rspec>, [">= 0"])
      s.add_development_dependency(%q<picky-client>, ["#<Syck::DefaultKey:0x1f33b84> 3.3.2"])
      s.add_runtime_dependency(%q<rack>, [">= 0"])
      s.add_runtime_dependency(%q<rack_fast_escape>, [">= 0"])
      s.add_runtime_dependency(%q<text>, [">= 0"])
      s.add_runtime_dependency(%q<yajl-ruby>, [">= 0"])
      s.add_runtime_dependency(%q<activesupport>, ["~> 3.0"])
      s.add_runtime_dependency(%q<activerecord>, ["~> 3.0"])
      s.add_runtime_dependency(%q<unicorn>, [">= 0"])
      s.add_runtime_dependency(%q<sinatra>, [">= 0"])
      s.add_runtime_dependency(%q<redis>, [">= 0"])
      s.add_runtime_dependency(%q<mysql>, [">= 0"])
    else
      s.add_dependency(%q<rspec>, [">= 0"])
      s.add_dependency(%q<picky-client>, ["#<Syck::DefaultKey:0x1f33b84> 3.3.2"])
      s.add_dependency(%q<rack>, [">= 0"])
      s.add_dependency(%q<rack_fast_escape>, [">= 0"])
      s.add_dependency(%q<text>, [">= 0"])
      s.add_dependency(%q<yajl-ruby>, [">= 0"])
      s.add_dependency(%q<activesupport>, ["~> 3.0"])
      s.add_dependency(%q<activerecord>, ["~> 3.0"])
      s.add_dependency(%q<unicorn>, [">= 0"])
      s.add_dependency(%q<sinatra>, [">= 0"])
      s.add_dependency(%q<redis>, [">= 0"])
      s.add_dependency(%q<mysql>, [">= 0"])
    end
  else
    s.add_dependency(%q<rspec>, [">= 0"])
    s.add_dependency(%q<picky-client>, ["#<Syck::DefaultKey:0x1f33b84> 3.3.2"])
    s.add_dependency(%q<rack>, [">= 0"])
    s.add_dependency(%q<rack_fast_escape>, [">= 0"])
    s.add_dependency(%q<text>, [">= 0"])
    s.add_dependency(%q<yajl-ruby>, [">= 0"])
    s.add_dependency(%q<activesupport>, ["~> 3.0"])
    s.add_dependency(%q<activerecord>, ["~> 3.0"])
    s.add_dependency(%q<unicorn>, [">= 0"])
    s.add_dependency(%q<sinatra>, [">= 0"])
    s.add_dependency(%q<redis>, [">= 0"])
    s.add_dependency(%q<mysql>, [">= 0"])
  end
end
Florian R. Hanke
Owner

Hi Roger, thanks for the issue!

I'm having trouble reproducing this error. I'm using
ruby 1.9.3p0 (2011-10-30 revision 33570) [x86_64-darwin11.2.0]
with
RubyGems 1.8.11 (as are you).

Although it is not the exact same error message, it might be related to this:
http://blog.rubygems.org/2011/08/31/shaving-the-yaml-yak.html
and the problem is on RubyGems.

If you need it in a hurry, it is possible to manually fix it.

I'm not sure I'm reading the reference you included correctly. Do they suggest that we start using ~> 1.0.0 instead of = 1.0.0 or just 1.0.0? But apparently, apart from fixing rubygems.org, this seems to be a thing we can do from our side.

Let's try the ~>. Why would I ever use =, you ask? I'd like to use the exact same version of the client as for the server in development. Although I can live with ~>, since that is in a way "more correct".

Now, I'm going to release 3.3.3 (Schnaps, please! :D) in around 15 minutes. Could you please give me feedback if it works?

Florian R. Hanke floere referenced this issue from a commit
Florian R. Hanke ! #38 6ad750c
Florian R. Hanke
Owner

It is released. Anyone quickly try this, please?

Roger Braun

It's fixed, thank you! Honestly, I still don't really understand where this problem happens.

FYI, the exact version of Ruby I run is ruby 1.9.2p290 (2011-07-09 revision 32553) [i386-darwin9.8.0].

Niko Dittmann

here, too. :)

Florian R. Hanke
Owner

Thanks for the info!

Maybe see the explanation in http://blog.rubygems.org/2011/08/31/shaving-the-yaml-yak.html just before "We can get Syck to return a strange object even when given a valid YAML document".

Florian R. Hanke
Owner

@rogerbraun & @niko: I can now say with relatively high confidence that the issue is solved in Germany ;)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.