New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Login not redirecting when global tenant is disabled #411

Closed
cyramica opened this Issue Nov 21, 2017 · 2 comments

Comments

Projects
None yet
3 participants
@cyramica

cyramica commented Nov 21, 2017

Using:

Elasticsearch 6.0.0
search-guard-6-6.0.0-17.beta1.zip
search-guard-kibana-plugin-6.0.0-beta1
openjdk version 1.8.0_151
Red Hat Enterprise Linux Server release 7.3

It appears that when the global tenant is disabled as such in kibana.yml:
searchguard.multitenancy.tenants.enable_global: false
then the user is not redirected after login but instead just sees the login page again without any messages.

In the kibana log file the only part that changes is the referer
from "referer":"http://10.51.8.220:5601/login?nextUrl=%2F"
to "referer":"http://10.51.8.220:5601/login"

If the user removes all parts of the address trailing the port number then the session allows them to get into Kibana.

@floragunncom floragunncom added the SG6 label Nov 21, 2017

@floragunncom

This comment has been minimized.

Show comment
Hide comment
@floragunncom

floragunncom Nov 30, 2017

Owner

Confirmed as bug, will be fixed in the next release, thanks for reporting!

Owner

floragunncom commented Nov 30, 2017

Confirmed as bug, will be fixed in the next release, thanks for reporting!

@floragunncom floragunncom added the bug label Nov 30, 2017

@jochenkressin

This comment has been minimized.

Show comment
Hide comment
@jochenkressin

jochenkressin Dec 23, 2017

Collaborator

Fixed in 6.1.0-8

Collaborator

jochenkressin commented Dec 23, 2017

Fixed in 6.1.0-8

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment