New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Please release a gem new version for Ruby 2.4 compatibility #286

Closed
samgranieri opened this Issue Jun 21, 2016 · 0 comments

Comments

Projects
None yet
2 participants
@samgranieri

samgranieri commented Jun 21, 2016

I'm trying out 2.4.0-preview1, and json v1.8.3 (from gem install json) won't compile due to Bignum/Fixnum integration that landed in 2.4, but the master branch will.

@flori flori closed this Jul 1, 2016

nougad added a commit to nougad/freshcerts that referenced this issue Jan 16, 2017

myfreeweb added a commit to myfreeweb/freshcerts that referenced this issue Jan 16, 2017

mshenfield pushed a commit to mshenfield/CutePets that referenced this issue Sep 23, 2017

Issue 58: Bump ruby version to 2.4.2
Closes #58. 2.4.2 is the latest version of ruby [supported by Heroku](https://devcenter.heroku.com/articles/ruby-support#supported-runtimes). The current version is causing deploys of this app to Heroku to fail.

I wasn't able to test the changes locally because of a [known issue](flori/json#286) building json 1.8.3, a dependency of the "twitter" gem. I'm using the build process on Heroku and Travis as a barometer of "this works".

mshenfield pushed a commit to mshenfield/CutePets that referenced this issue Sep 23, 2017

Issue 58: Bump ruby version to 2.4.2
Closes #58. 2.4.2 is the latest version of ruby [supported by Heroku](https://devcenter.heroku.com/articles/ruby-support#supported-runtimes). The current version is causing deploys of this app to Heroku to fail.

I wasn't able to test the changes locally because of a [known issue](flori/json#286) building json 1.8.3, a dependency of the "twitter" gem. I'm using the build process on Heroku and Travis as a barometer of "this works".

mshenfield pushed a commit to mshenfield/CutePets that referenced this issue Sep 23, 2017

Issue 58: Bump ruby version to 2.3.5
Closes #58. 2.3.5 is the latest version of ruby [supported by Heroku](https://devcenter.heroku.com/articles/ruby-support#supported-runtimes) and `json` 1.8.1. The current version is causing deploys of this app to Heroku to fail.

I wasn't able to test the changes locally because of a [known issue](flori/json#286) building json 1.8.3, a dependency of the "twitter" gem. I'm using the build process on Heroku and Travis as a barometer of "this works".

mshenfield pushed a commit to mshenfield/CutePets that referenced this issue Sep 23, 2017

Issue 58: Bump ruby version to 2.2.8
Closes #58. 2.2.8 is the latest version of ruby [supported by Heroku](https://devcenter.heroku.com/articles/ruby-support#supported-runtimes) and `json` 1.8.1. The current version is causing deploys of this app to Heroku to fail.

I wasn't able to test the changes locally because of a [known issue](flori/json#286) building json 1.8.3, a dependency of the "twitter" gem. I'm using the build process on Heroku and Travis as a barometer of "this works".

mshenfield pushed a commit to mshenfield/CutePets that referenced this issue Sep 23, 2017

Issue 58: Bump ruby version to 2.4.2
Closes #58. 2.4.2 is the latest version of ruby [supported by Heroku](https://devcenter.heroku.com/articles/ruby-support#supported-runtimes). The current version is causing deploys of this app to Heroku to fail.

This also updates the `json` version in the lockfile [known issue](flori/json#286) causing it to fail to build locally or on Heroku.

mshenfield pushed a commit to mshenfield/CutePets that referenced this issue Sep 23, 2017

Issue 58: Bump ruby version to 2.4.2
Closes #58. 2.4.2 is the latest version of ruby [supported by Heroku](https://devcenter.heroku.com/articles/ruby-support#supported-runtimes). The current version is causing deploys of this app to Heroku to fail.

This also updates various dependencies in the lockfile using `bundle update #{name}` because of issues related to newer versions of ruby.

- `json` [⚠](flori/json#286)
- `safe_yaml` [⚠](dtao/safe_yaml#67)
- `webmock` [⚠] (bblimke/webmock#683)

For folks that have this checked out locally, I also had to `brew install --force` to force an up to date build of `http_parse.rb`, which was throwing `Symbol not found: _rb_cFixnum`.

Finally, this updates petharbor cassette to include URL encoded quotes - this is probably just an internal change to `URI.encode_www_form`.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment