jQuery minimum version requirement since 0.8.2 #1240

Closed
ngavard opened this Issue Feb 3, 2014 · 2 comments

Comments

Projects
None yet
2 participants

ngavard commented Feb 3, 2014

Hi,
We are using Richfaces 3.3.3 that ship jquery 1.3.2.
In the flot's readme, it is said :
You need at least jQuery 1.2.6, but try at least 1.3.2 for interactive charts because of performance improvements in event handling.
That seems good to me :)
But, I'm just upgrading flot from 0.7 to 0.8.2 and it seems that there is a call to element.detach(). Can you confirm this is a function from jQuery 1.4 ?

If so, I need to know if there is a chance to see the backward compatibility be restored to 1.3.2 (at least) or if I have to upgrade my components.

Thanks for any comment.

@dnschnur dnschnur self-assigned this Feb 4, 2014

Owner

dnschnur commented Feb 4, 2014

Thanks for the report; we'll fix this in 0.8.3.

Please note, however, that Flot 0.9's minimum jQuery version will be 1.4.4.

ngavard commented Feb 4, 2014

Thanks for your quick answer.

dnschnur added a commit to dnschnur/flot that referenced this issue Apr 15, 2014

Provide a detach shim for jQuery prior to 1.4.
Flot 0.8 still officially supports jQuery 1.2.6 and higher, so we can’t
assume the existence of detach.  This will go away in 0.9, where the
minimum jQuery version is 1.4.4.

Fixes #1240.

@dnschnur dnschnur closed this in #1286 Apr 16, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment