Skip to content

Further problems with navigate and jQuery 1.9 #964

Closed
dnschnur opened this Issue Feb 19, 2013 · 2 comments

2 participants

@dnschnur
Flot member

See https://groups.google.com/forum/?fromgroups=#!topic/flot-graphs/qO9BqizqYM8.

It looks like the inline event.drag isn't compatible with jQuery 1.9.1.

@hadalin
hadalin commented Feb 20, 2013

I can confirm this. Replaced event.drag with the latest version (2.2) and started working.

@dnschnur dnschnur was assigned Feb 20, 2013
@dnschnur dnschnur added a commit that referenced this issue Feb 22, 2013
@dnschnur dnschnur Fixed inline event.drag's use of $.event.handle.
This resolves issue #964.
1774536
@dnschnur
Flot member

My first thought was to upgrade to event.drag 2.2, but it looks like the authors are more aggressive about requiring recent jQuery versions than we are; it needs 1.7+. In fact we officially still support jQuery 1.2.6, and event.drag 1.5 is the last version to support jQuery 1.2.x. We probably don't need to support jQuery back that far, but I'd rather deal with that in 0.9, not right before we release 0.8.

For now I took a look at why the script was failing, and it's actually very simple: on line 117 of the original source the plugin uses $.event.handle, an internal undocumented function that was removed in 1.9.x. Fortunately there is a function $.event.dispatch that does the same thing, so it was an easy fix.

@dnschnur dnschnur closed this Feb 22, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.