Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 161 lines (155 sloc) 6.215 kb
963ce63 @frsyuki added fluentd.gemspec
frsyuki authored
1 # Generated by jeweler
2 # DO NOT EDIT THIS FILE DIRECTLY
3 # Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
4 # -*- encoding: utf-8 -*-
5
6 Gem::Specification.new do |s|
7 s.name = "fluentd"
bd6feb0 @frsyuki workaround for fluentd >=0 dependency problem
frsyuki authored
8 s.version = "0.10.14"
963ce63 @frsyuki added fluentd.gemspec
frsyuki authored
9
10 s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
11 s.authors = ["Sadayuki Furuhashi"]
bd6feb0 @frsyuki workaround for fluentd >=0 dependency problem
frsyuki authored
12 s.date = "2012-03-07"
963ce63 @frsyuki added fluentd.gemspec
frsyuki authored
13 s.email = "frsyuki@gmail.com"
14 s.executables = ["fluentd", "fluent-cat", "fluent-gem"]
15 s.extra_rdoc_files = [
16 "ChangeLog",
bd6feb0 @frsyuki workaround for fluentd >=0 dependency problem
frsyuki authored
17 "README",
963ce63 @frsyuki added fluentd.gemspec
frsyuki authored
18 "README.rdoc"
19 ]
20 s.files = [
21 "AUTHORS",
22 "COPYING",
bfacd18 @hotchpotch Added development dependency gem & regenerate fluentd.gemspec
hotchpotch authored
23 "Gemfile",
963ce63 @frsyuki added fluentd.gemspec
frsyuki authored
24 "Rakefile",
25 "VERSION",
26 "bin/fluent-cat",
27 "bin/fluent-gem",
28 "bin/fluentd",
29 "fluent.conf",
30 "fluentd.gemspec",
31 "lib/fluent/buffer.rb",
32 "lib/fluent/command/cat.rb",
33 "lib/fluent/command/fluentd.rb",
34 "lib/fluent/config.rb",
35 "lib/fluent/engine.rb",
36 "lib/fluent/env.rb",
37 "lib/fluent/event.rb",
38 "lib/fluent/input.rb",
39 "lib/fluent/load.rb",
40 "lib/fluent/log.rb",
41 "lib/fluent/match.rb",
42 "lib/fluent/mixin.rb",
43 "lib/fluent/output.rb",
44 "lib/fluent/parser.rb",
45 "lib/fluent/plugin.rb",
46 "lib/fluent/plugin/buf_file.rb",
47 "lib/fluent/plugin/buf_memory.rb",
48 "lib/fluent/plugin/buf_zfile.rb",
49 "lib/fluent/plugin/in_exec.rb",
50 "lib/fluent/plugin/in_forward.rb",
51 "lib/fluent/plugin/in_http.rb",
bfacd18 @hotchpotch Added development dependency gem & regenerate fluentd.gemspec
hotchpotch authored
52 "lib/fluent/plugin/in_status.rb",
963ce63 @frsyuki added fluentd.gemspec
frsyuki authored
53 "lib/fluent/plugin/in_stream.rb",
54 "lib/fluent/plugin/in_syslog.rb",
55 "lib/fluent/plugin/in_tail.rb",
56 "lib/fluent/plugin/out_copy.rb",
57 "lib/fluent/plugin/out_exec.rb",
58 "lib/fluent/plugin/out_exec_filter.rb",
59 "lib/fluent/plugin/out_file.rb",
60 "lib/fluent/plugin/out_forward.rb",
61 "lib/fluent/plugin/out_null.rb",
62 "lib/fluent/plugin/out_roundrobin.rb",
63 "lib/fluent/plugin/out_stdout.rb",
64 "lib/fluent/plugin/out_stream.rb",
65 "lib/fluent/plugin/out_test.rb",
66 "lib/fluent/process.rb",
bfacd18 @hotchpotch Added development dependency gem & regenerate fluentd.gemspec
hotchpotch authored
67 "lib/fluent/status.rb",
963ce63 @frsyuki added fluentd.gemspec
frsyuki authored
68 "lib/fluent/supervisor.rb",
69 "lib/fluent/test.rb",
70 "lib/fluent/test/base.rb",
71 "lib/fluent/test/input_test.rb",
72 "lib/fluent/test/output_test.rb",
73 "lib/fluent/version.rb",
74 "test/config.rb",
75 "test/helper.rb",
76 "test/match.rb",
77 "test/mixin.rb",
78 "test/plugin/in_exec.rb",
79 "test/plugin/in_forward.rb",
80 "test/plugin/in_http.rb",
81 "test/plugin/in_stream.rb",
82 "test/plugin/out_copy.rb",
83 "test/plugin/out_exec.rb",
84 "test/plugin/out_exec_filter.rb",
85 "test/plugin/out_file.rb",
86 "test/plugin/out_forward.rb",
87 "test/plugin/out_roundrobin.rb",
88 "test/plugin/out_stream.rb"
89 ]
90 s.homepage = "http://fluentd.org/"
91 s.require_paths = ["lib"]
92 s.required_ruby_version = Gem::Requirement.new("~> 1.9.2")
bd6feb0 @frsyuki workaround for fluentd >=0 dependency problem
frsyuki authored
93 s.rubygems_version = "1.8.12"
963ce63 @frsyuki added fluentd.gemspec
frsyuki authored
94 s.summary = "Fluent event collector"
95 s.test_files = ["test/config.rb", "test/helper.rb", "test/match.rb", "test/mixin.rb", "test/plugin/in_exec.rb", "test/plugin/in_forward.rb", "test/plugin/in_http.rb", "test/plugin/in_stream.rb", "test/plugin/out_copy.rb", "test/plugin/out_exec.rb", "test/plugin/out_exec_filter.rb", "test/plugin/out_file.rb", "test/plugin/out_forward.rb", "test/plugin/out_roundrobin.rb", "test/plugin/out_stream.rb"]
96
97 if s.respond_to? :specification_version then
98 s.specification_version = 3
99
100 if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
bfacd18 @hotchpotch Added development dependency gem & regenerate fluentd.gemspec
hotchpotch authored
101 s.add_runtime_dependency(%q<fluentd>, [">= 0"])
102 s.add_development_dependency(%q<rake>, [">= 0.9.2"])
bd6feb0 @frsyuki workaround for fluentd >=0 dependency problem
frsyuki authored
103 s.add_development_dependency(%q<rr>, [">= 1.0.0"])
104 s.add_development_dependency(%q<timecop>, [">= 0.3.0"])
105 s.add_development_dependency(%q<jeweler>, [">= 1.0.0"])
106 s.add_development_dependency(%q<rake>, [">= 0.9.2"])
107 s.add_development_dependency(%q<rr>, [">= 1.0.0"])
108 s.add_development_dependency(%q<timecop>, [">= 0.3.0"])
109 s.add_development_dependency(%q<jeweler>, [">= 1.0.0"])
963ce63 @frsyuki added fluentd.gemspec
frsyuki authored
110 s.add_runtime_dependency(%q<msgpack>, ["~> 0.4.4"])
111 s.add_runtime_dependency(%q<json>, [">= 1.4.3"])
707ff6d @frsyuki changed dependency yajl-ruby from '~> 1.0.0' to '~> 1.0'
frsyuki authored
112 s.add_runtime_dependency(%q<yajl-ruby>, ["~> 1.0"])
963ce63 @frsyuki added fluentd.gemspec
frsyuki authored
113 s.add_runtime_dependency(%q<cool.io>, ["~> 1.1.0"])
114 s.add_runtime_dependency(%q<http_parser.rb>, ["~> 0.5.1"])
115 s.add_development_dependency(%q<rake>, [">= 0.9.2"])
bfacd18 @hotchpotch Added development dependency gem & regenerate fluentd.gemspec
hotchpotch authored
116 s.add_development_dependency(%q<rr>, [">= 1.0.0"])
117 s.add_development_dependency(%q<timecop>, [">= 0.3.0"])
118 s.add_development_dependency(%q<jeweler>, [">= 1.0.0"])
963ce63 @frsyuki added fluentd.gemspec
frsyuki authored
119 else
bfacd18 @hotchpotch Added development dependency gem & regenerate fluentd.gemspec
hotchpotch authored
120 s.add_dependency(%q<fluentd>, [">= 0"])
121 s.add_dependency(%q<rake>, [">= 0.9.2"])
bd6feb0 @frsyuki workaround for fluentd >=0 dependency problem
frsyuki authored
122 s.add_dependency(%q<rr>, [">= 1.0.0"])
123 s.add_dependency(%q<timecop>, [">= 0.3.0"])
124 s.add_dependency(%q<jeweler>, [">= 1.0.0"])
125 s.add_dependency(%q<rake>, [">= 0.9.2"])
126 s.add_dependency(%q<rr>, [">= 1.0.0"])
127 s.add_dependency(%q<timecop>, [">= 0.3.0"])
128 s.add_dependency(%q<jeweler>, [">= 1.0.0"])
963ce63 @frsyuki added fluentd.gemspec
frsyuki authored
129 s.add_dependency(%q<msgpack>, ["~> 0.4.4"])
130 s.add_dependency(%q<json>, [">= 1.4.3"])
707ff6d @frsyuki changed dependency yajl-ruby from '~> 1.0.0' to '~> 1.0'
frsyuki authored
131 s.add_dependency(%q<yajl-ruby>, ["~> 1.0"])
963ce63 @frsyuki added fluentd.gemspec
frsyuki authored
132 s.add_dependency(%q<cool.io>, ["~> 1.1.0"])
133 s.add_dependency(%q<http_parser.rb>, ["~> 0.5.1"])
134 s.add_dependency(%q<rake>, [">= 0.9.2"])
bfacd18 @hotchpotch Added development dependency gem & regenerate fluentd.gemspec
hotchpotch authored
135 s.add_dependency(%q<rr>, [">= 1.0.0"])
136 s.add_dependency(%q<timecop>, [">= 0.3.0"])
137 s.add_dependency(%q<jeweler>, [">= 1.0.0"])
963ce63 @frsyuki added fluentd.gemspec
frsyuki authored
138 end
139 else
bfacd18 @hotchpotch Added development dependency gem & regenerate fluentd.gemspec
hotchpotch authored
140 s.add_dependency(%q<fluentd>, [">= 0"])
141 s.add_dependency(%q<rake>, [">= 0.9.2"])
bd6feb0 @frsyuki workaround for fluentd >=0 dependency problem
frsyuki authored
142 s.add_dependency(%q<rr>, [">= 1.0.0"])
143 s.add_dependency(%q<timecop>, [">= 0.3.0"])
144 s.add_dependency(%q<jeweler>, [">= 1.0.0"])
145 s.add_dependency(%q<rake>, [">= 0.9.2"])
146 s.add_dependency(%q<rr>, [">= 1.0.0"])
147 s.add_dependency(%q<timecop>, [">= 0.3.0"])
148 s.add_dependency(%q<jeweler>, [">= 1.0.0"])
963ce63 @frsyuki added fluentd.gemspec
frsyuki authored
149 s.add_dependency(%q<msgpack>, ["~> 0.4.4"])
150 s.add_dependency(%q<json>, [">= 1.4.3"])
707ff6d @frsyuki changed dependency yajl-ruby from '~> 1.0.0' to '~> 1.0'
frsyuki authored
151 s.add_dependency(%q<yajl-ruby>, ["~> 1.0"])
963ce63 @frsyuki added fluentd.gemspec
frsyuki authored
152 s.add_dependency(%q<cool.io>, ["~> 1.1.0"])
153 s.add_dependency(%q<http_parser.rb>, ["~> 0.5.1"])
154 s.add_dependency(%q<rake>, [">= 0.9.2"])
bfacd18 @hotchpotch Added development dependency gem & regenerate fluentd.gemspec
hotchpotch authored
155 s.add_dependency(%q<rr>, [">= 1.0.0"])
156 s.add_dependency(%q<timecop>, [">= 0.3.0"])
157 s.add_dependency(%q<jeweler>, [">= 1.0.0"])
963ce63 @frsyuki added fluentd.gemspec
frsyuki authored
158 end
159 end
160
Something went wrong with that request. Please try again.