Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Added development dependency gem & regenerate fluentd.gemspec

  • Loading branch information...
commit bfacd18f87f579cfaad0cacce9b454a6a2c1edac 1 parent bb205dc
@hotchpotch hotchpotch authored
Showing with 25 additions and 4 deletions.
  1. +3 −0  Gemfile
  2. +2 −1  Rakefile
  3. +20 −3 fluentd.gemspec
View
3  Gemfile
@@ -0,0 +1,3 @@
+source :rubygems
+
+gemspec
View
3  Rakefile
@@ -20,9 +20,10 @@ begin
gemspec.add_development_dependency "rake", ">= 0.9.2"
gemspec.add_development_dependency "rr", ">= 1.0.0"
gemspec.add_development_dependency "timecop", ">= 0.3.0"
+ gemspec.add_development_dependency "jeweler", ">= 1.0.0"
gemspec.test_files = Dir["test/**/*.rb"]
gemspec.files = Dir["bin/**/*", "lib/**/*", "test/**/*.rb"] +
- %w[fluent.conf VERSION AUTHORS Rakefile COPYING fluentd.gemspec]
+ %w[fluent.conf VERSION AUTHORS Rakefile COPYING fluentd.gemspec Gemfile]
gemspec.executables = ['fluentd', 'fluent-cat', 'fluent-gem']
gemspec.required_ruby_version = '~> 1.9.2'
end
View
23 fluentd.gemspec
@@ -9,17 +9,17 @@ Gem::Specification.new do |s|
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Sadayuki Furuhashi"]
- s.date = "2012-03-01"
+ s.date = "2012-03-05"
s.email = "frsyuki@gmail.com"
s.executables = ["fluentd", "fluent-cat", "fluent-gem"]
s.extra_rdoc_files = [
"ChangeLog",
- "README",
"README.rdoc"
]
s.files = [
"AUTHORS",
"COPYING",
+ "Gemfile",
"Rakefile",
"VERSION",
"bin/fluent-cat",
@@ -48,6 +48,7 @@ Gem::Specification.new do |s|
"lib/fluent/plugin/in_exec.rb",
"lib/fluent/plugin/in_forward.rb",
"lib/fluent/plugin/in_http.rb",
+ "lib/fluent/plugin/in_status.rb",
"lib/fluent/plugin/in_stream.rb",
"lib/fluent/plugin/in_syslog.rb",
"lib/fluent/plugin/in_tail.rb",
@@ -62,6 +63,7 @@ Gem::Specification.new do |s|
"lib/fluent/plugin/out_stream.rb",
"lib/fluent/plugin/out_test.rb",
"lib/fluent/process.rb",
+ "lib/fluent/status.rb",
"lib/fluent/supervisor.rb",
"lib/fluent/test.rb",
"lib/fluent/test/base.rb",
@@ -87,7 +89,7 @@ Gem::Specification.new do |s|
s.homepage = "http://fluentd.org/"
s.require_paths = ["lib"]
s.required_ruby_version = Gem::Requirement.new("~> 1.9.2")
- s.rubygems_version = "1.8.12"
+ s.rubygems_version = "1.8.11"
s.summary = "Fluent event collector"
s.test_files = ["test/config.rb", "test/helper.rb", "test/match.rb", "test/mixin.rb", "test/plugin/in_exec.rb", "test/plugin/in_forward.rb", "test/plugin/in_http.rb", "test/plugin/in_stream.rb", "test/plugin/out_copy.rb", "test/plugin/out_exec.rb", "test/plugin/out_exec_filter.rb", "test/plugin/out_file.rb", "test/plugin/out_forward.rb", "test/plugin/out_roundrobin.rb", "test/plugin/out_stream.rb"]
@@ -95,27 +97,42 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
+ s.add_runtime_dependency(%q<fluentd>, [">= 0"])
+ s.add_development_dependency(%q<rake>, [">= 0.9.2"])
s.add_runtime_dependency(%q<msgpack>, ["~> 0.4.4"])
s.add_runtime_dependency(%q<json>, [">= 1.4.3"])
s.add_runtime_dependency(%q<yajl-ruby>, ["~> 1.0.0"])
s.add_runtime_dependency(%q<cool.io>, ["~> 1.1.0"])
s.add_runtime_dependency(%q<http_parser.rb>, ["~> 0.5.1"])
s.add_development_dependency(%q<rake>, [">= 0.9.2"])
+ s.add_development_dependency(%q<rr>, [">= 1.0.0"])
+ s.add_development_dependency(%q<timecop>, [">= 0.3.0"])
+ s.add_development_dependency(%q<jeweler>, [">= 1.0.0"])
else
+ s.add_dependency(%q<fluentd>, [">= 0"])
+ s.add_dependency(%q<rake>, [">= 0.9.2"])
s.add_dependency(%q<msgpack>, ["~> 0.4.4"])
s.add_dependency(%q<json>, [">= 1.4.3"])
s.add_dependency(%q<yajl-ruby>, ["~> 1.0.0"])
s.add_dependency(%q<cool.io>, ["~> 1.1.0"])
s.add_dependency(%q<http_parser.rb>, ["~> 0.5.1"])
s.add_dependency(%q<rake>, [">= 0.9.2"])
+ s.add_dependency(%q<rr>, [">= 1.0.0"])
+ s.add_dependency(%q<timecop>, [">= 0.3.0"])
+ s.add_dependency(%q<jeweler>, [">= 1.0.0"])
end
else
+ s.add_dependency(%q<fluentd>, [">= 0"])
+ s.add_dependency(%q<rake>, [">= 0.9.2"])
s.add_dependency(%q<msgpack>, ["~> 0.4.4"])
s.add_dependency(%q<json>, [">= 1.4.3"])
s.add_dependency(%q<yajl-ruby>, ["~> 1.0.0"])
s.add_dependency(%q<cool.io>, ["~> 1.1.0"])
s.add_dependency(%q<http_parser.rb>, ["~> 0.5.1"])
s.add_dependency(%q<rake>, [">= 0.9.2"])
+ s.add_dependency(%q<rr>, [">= 1.0.0"])
+ s.add_dependency(%q<timecop>, [">= 0.3.0"])
+ s.add_dependency(%q<jeweler>, [">= 1.0.0"])
end
end
Please sign in to comment.
Something went wrong with that request. Please try again.