remove jeweler, and fix to depend gem building on bundler #61

Closed
wants to merge 1 commit into
from

Conversation

Projects
None yet
4 participants
@tagomoris
Owner

tagomoris commented Aug 15, 2012

Fix Gemfile/Rakefile/gemspec to use bundler for building .gem
'jeweler' is not maintained today.

@repeatedly

This comment has been minimized.

Show comment Hide comment
@repeatedly

repeatedly Aug 15, 2012

Owner

LGTM 👍

Owner

repeatedly commented Aug 15, 2012

LGTM 👍

@tagomoris

This comment has been minimized.

Show comment Hide comment
@tagomoris

tagomoris Aug 15, 2012

Owner

NOTE: someone must edit gem.description before first release with this gemspec

Owner

tagomoris commented Aug 15, 2012

NOTE: someone must edit gem.description before first release with this gemspec

@frsyuki

This comment has been minimized.

Show comment Hide comment
@frsyuki

frsyuki Aug 18, 2012

Owner

I agree jeweler is obsoleted and bundler is better.
But when we once switched to bundler, it caused a problem for RPM/deb packaging.
(b8871f8 and 165a572)
So we need to fix the packaging scripts first at the same time.

Owner

frsyuki commented Aug 18, 2012

I agree jeweler is obsoleted and bundler is better.
But when we once switched to bundler, it caused a problem for RPM/deb packaging.
(b8871f8 and 165a572)
So we need to fix the packaging scripts first at the same time.

@frsyuki

This comment has been minimized.

Show comment Hide comment
@frsyuki

frsyuki Sep 26, 2012

Owner

Sorry, this issue is taking time...

Owner

frsyuki commented Sep 26, 2012

Sorry, this issue is taking time...

@tagomoris

This comment has been minimized.

Show comment Hide comment
@tagomoris

tagomoris Mar 15, 2013

Owner

Ruby 2.0.0 doesn't have 'rubygems/builder', so we cannot rake build with jeweler...

Owner

tagomoris commented Mar 15, 2013

Ruby 2.0.0 doesn't have 'rubygems/builder', so we cannot rake build with jeweler...

@repeatedly

This comment has been minimized.

Show comment Hide comment
@repeatedly

repeatedly Mar 21, 2013

Owner

treasure-data/td-agent@8e21c23

I tried above commit and building td-agent RPM succeeded on CentOS 6.4.

I am now trying deb package with bundler based fluentd.
But unfortunately, I can't build the deb package in the first place.
Need more time...

Owner

repeatedly commented Mar 21, 2013

treasure-data/td-agent@8e21c23

I tried above commit and building td-agent RPM succeeded on CentOS 6.4.

I am now trying deb package with bundler based fluentd.
But unfortunately, I can't build the deb package in the first place.
Need more time...

@suupic

This comment has been minimized.

Show comment Hide comment
@suupic

suupic Mar 23, 2013

I switch jeweler to bundler and build rpm use td-agent's build script, it works fine

suupic commented Mar 23, 2013

I switch jeweler to bundler and build rpm use td-agent's build script, it works fine

@repeatedly

This comment has been minimized.

Show comment Hide comment
@repeatedly

repeatedly Mar 23, 2013

Owner

@suupic

build rpm use td-agnet's build script, it works fine

Which branch did you use, master or bundler-fluentd-support?

Owner

repeatedly commented Mar 23, 2013

@suupic

build rpm use td-agnet's build script, it works fine

Which branch did you use, master or bundler-fluentd-support?

@suupic

This comment has been minimized.

Show comment Hide comment
@suupic

suupic Mar 24, 2013

@repeatedly
I use master, but I replaced Rakefile and fluentd.gemspec. Those two file come from branch goodbye-jeweler.
but I only tied rpm, not deb

suupic commented Mar 24, 2013

@repeatedly
I use master, but I replaced Rakefile and fluentd.gemspec. Those two file come from branch goodbye-jeweler.
but I only tied rpm, not deb

@tagomoris tagomoris closed this Mar 28, 2013

@tagomoris tagomoris deleted the tagomoris:bundlernize branch Mar 28, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment