Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Enable logcat and android profiler from flutter projects #16691

Closed
fmatosqg opened this issue Apr 18, 2018 · 13 comments
Closed

Enable logcat and android profiler from flutter projects #16691

fmatosqg opened this issue Apr 18, 2018 · 13 comments

Comments

@fmatosqg
Copy link
Contributor

@fmatosqg fmatosqg commented Apr 18, 2018

They still contain valuable features that can be used while debugging, allowing for skipping opening android module.

@fmatosqg fmatosqg changed the title Enable logcat and anroid profiler from flutter projects Enable logcat and android profiler from flutter projects Apr 18, 2018
@zoechi

This comment has been minimized.

Copy link
Contributor

@zoechi zoechi commented Apr 18, 2018

Can you elaborate more what the request is about?
Is this about IDE support?
adb logcat works with Flutter apps.
(I don't know about Android profiler.)

@fmatosqg

This comment has been minimized.

Copy link
Contributor Author

@fmatosqg fmatosqg commented Apr 18, 2018

Android Studio support. Those panels are visible for Android projects but not for Flutter ones.

@zoechi

This comment has been minimized.

Copy link
Contributor

@zoechi zoechi commented Jul 16, 2018

Is this still missing in AS?
IntelliJ provides that view

image

@ricardobrg

This comment has been minimized.

Copy link

@ricardobrg ricardobrg commented Jul 27, 2018

It's not woking in AS for me... It says "Configure Android SDK" but it is configured already...

I'm working with AS 3.1.3 in Ubuntu 18.04

When I need logcat I use adb shell in the console...

@zoechi

This comment has been minimized.

Copy link
Contributor

@zoechi zoechi commented Jul 27, 2018

@ricardobrg That sounds like a different problem. Please create a new issue with the issue template filled out.

@ricardobrg

This comment has been minimized.

Copy link

@ricardobrg ricardobrg commented Jul 27, 2018

@zoechi I don't think that it's different... I just wanted to add some info since it was waiting response from OP. In Android Studio the logcat panel doesn't work with flutter projects.
captura de tela de 2018-07-27 11-08-55
It says "Configure Android SDK" but it's already configured. I'm able to debug Android apps using the debugger but not the logcat.

@zoechi

This comment has been minimized.

Copy link
Contributor

@zoechi zoechi commented Jul 27, 2018

Works the same in IntelliJ and Android Studio for a simple Flutter project.

image

Do you have Android SDK configured in

image

@no-response no-response bot closed this Aug 15, 2018
@no-response

This comment has been minimized.

Copy link

@no-response no-response bot commented Aug 15, 2018

Without additional information, we are unfortunately not sure how to resolve this issue. We are therefore reluctantly going to close this bug for now. Please don't hesitate to comment on the bug if you have any more information for us; we will reopen it right away!
Thanks for your contribution.
cc @Hixie

@HassanMeer

This comment has been minimized.

Copy link

@HassanMeer HassanMeer commented Dec 8, 2018

Goto File -> Project structure and choose your platform sdk,
api 27 ...ISSUE OF Logcat (Please configure SDK) will resolve INSHAllah .
adc4m

@hjJunior

This comment has been minimized.

Copy link

@hjJunior hjJunior commented Dec 19, 2018

To solve this problem I just opened on Android studio the android folder

@mpeng5120

This comment has been minimized.

Copy link

@mpeng5120 mpeng5120 commented Apr 28, 2019

Goto File -> Project structure and choose your platform sdk,
api 27 ...ISSUE OF Logcat (Please configure SDK) will resolve INSHAllah .
adc4m

this solve my problem thanks

@mofada

This comment has been minimized.

Copy link

@mofada mofada commented Oct 17, 2019

I have the same problem

image

image

@Kav47

This comment has been minimized.

Copy link

@Kav47 Kav47 commented Jan 11, 2020

To solve this:

  1. Go to Project Settings (File -> Project Structure)
  2. Change the Project SDK to API 27 ([Left Tab] Project Settings -> Project)

image

  1. Change "Build Target" for "Android API 27 Platform" to "Android API 28" ([Left Tab]Platform Settings -> SDKs)

image

  1. Then Click Apply and OK
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
8 participants
You can’t perform that action at this time.