Skip to content

Bad Builds

Amir Hardon edited this page Jul 15, 2019 · 89 revisions

This is a list of all the dev branch commits that are considered "bad" and should not be released to a more stable channel. See Bad Build Identification for details on how to identify builds that should be listed here. See also the Changelog.

If you add a build to this list and master has not yet been fixed, please file a TODAY bug and link to it from here as well.

v1.7.6 - v1.7.11

WebView is sized (0,0) for some pages on Android (https://github.com/flutter/flutter/issues/35291)

v1.7.6 - v1.7.7

v1.7.0 - v1.7.5

v1.7.1

v1.6.1 - v1.6.7

  • Android builds get stuck in the splash screen after deploying an APK from an app bundle (generated using flutter build appbundle)

v1.5.8 - v1.6.2

v1.5.3 - v1.6.0

v1.5.2 - 1.5.8

v1.3.10 - 1.5.8

v1.4.8 - v1.4.11

v1.4.0 - v1.4.8

v1.3.14

  • flutter upgrade will stash changes in the user's project folder.

v1.3.9 - v.1.3.13

v1.3.9

v1.2.2

v1.1.1 - v1.1.2

v0.11.6 - v0.11.9

v0.10.3 - v0.11.6

v0.10.0 - v0.11.1

  • Workflows that require customizing the underlying android or ios apps and newly created apps using cupertino_icons are broken by #22565.

v0.10.0

v0.9.6

  • Copy/pasting broken on iOS in material apps, see #22624.

v0.9.5 - v0.9.6

  • Upload to iOS app store is broken, see #22306.

v0.5.2 - v0.5.6

  • Dart VM crashes on certain eval calls, see #18573.

v0.4.2

  • Windows-specific bug in which android_arm release/profile snapshots build with hardfp when they should use softfp, see #17387.

v0.3.1 - ???

  • Accessibility on iOS is broken, see #16904.

v0.2.10 - v0.2.11, v0.3.0

  • iOS release binary sizes are bloated with image encoding support. The fix required an API update to Image.toByteData(). Since the API containing the image encoding was immediately changed, we don't want to release the bad API. #16537

v0.2.9

  • Android license status shows as "unknown" with certain Android SDK versions. #16228

v0.2.4 - v0.2.6

  • Flutter tool invocation from xcode_backend.sh never exits. #15944

v0.2.5

  • Tooltip of FAB doesn't end up as semantics label of FAB #16063

v0.2.4

  • Crash when doing full restart that spawns an isolate. #15894
  • Default TabBar indicatorColor doesn't contrast with its background. #15958

v0.1.6 - v0.1.8

  • flutter test loads test forever when run with --preview-dart-2. #14931

v0.0.23 - v0.1.4

  • Android Gallery gradle build fails on tagged commits without the -pre.x suffix. #14912

v0.1.1 - v0.1.2

  • Contain Dart SDK version 2.0.0-dev.23.0, which suffers from dart-lang/sdk#32172 and manifests to the user as #14696.
  • Suffer from #14751. They don't yet contain the change that unified the engine Dart SDK and the flutter tool Dart SDK, but these releases are prone to a different manifestation of the same problem with pub's version resolver checking the flutter tool's Dart SDK version and then running code against the engine Dart SDK version.

v0.0.22

  • Anecdotally, we've seen people complain more when using v0.0.22 than v0.0.21.

Flutter Wiki

Process

Framework repo

Engine repo

Infrastructure

Experimental features

Release Notes

Clone this wiki locally
You can’t perform that action at this time.