Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

docker: add yaml-cpp dependency #428

Merged
merged 3 commits into from Jan 15, 2019
Merged
Changes from 1 commit
Commits
File filter...
Filter file types
Jump to…
Jump to file or symbol
Failed to load files and symbols.
+4 −2
Diff settings

Always

Just for now

@@ -11,7 +11,8 @@ RUN sudo apt-get -qq install -y --no-install-recommends \
libboost-filesystem-dev \
libboost-regex-dev \
libxml2-dev \
python-yaml
python-yaml \

This comment has been minimized.

Copy link
@dongahn

dongahn Jan 15, 2019

Contributor

Looks good to me.

Using my web browser, I see an extra leading whitespace for the line before this (libxml2-dev). While you are on it, can we get rid of it.

Also, I just noticed our main README.md fails to list python-yaml and libyaml-cpp-dev as our dependencies. Do you think it makes sense to update that REAME.md as part of this PR as well?

This comment has been minimized.

Copy link
@garlick

garlick Jan 15, 2019

Author Member

Will address both - thanks!

libyaml-cpp-dev

# Add configured user to image with sudo access:
#
@@ -11,7 +11,8 @@ RUN sudo yum -y install \
libboost-regex-devel \
libxml2-devel \
readline-devel \
python-yaml
python-yaml \
yaml-cpp-devel

# Add configured user to image with sudo access:
#
ProTip! Use n and p to navigate between commits in a pull request.
You can’t perform that action at this time.