Skip to content
Newer
Older
100644 54 lines (49 sloc) 1.77 KB
95253d6 @flyerhzm release bullet-1.0.0 gem
authored Aug 26, 2009
1 # Generated by jeweler
2 # DO NOT EDIT THIS FILE
3 # Instead, edit Jeweler::Tasks in Rakefile, and run `rake gemspec`
4 # -*- encoding: utf-8 -*-
5
6 Gem::Specification.new do |s|
7 s.name = %q{bullet}
8 s.version = "1.0.0"
9
10 s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
11 s.authors = ["Richard Huang"]
12 s.date = %q{2009-08-26}
13 s.description = %q{This plugin is aimed to give you some performance suggestion about ActiveRecord usage, what should use but not use, such as eager loading, counter cache and so on, what should not use but use, such as unused eager loading. Now it provides you the suggestion of eager loading and unused eager loading. The others are todo, next may be couter cache.}
14 s.email = %q{flyerhzm@gmail.com}
15 s.extra_rdoc_files = [
16 "README.textile"
17 ]
18 s.files = [
19 "MIT-LICENSE",
20 "README.textile",
21 "Rakefile",
22 "VERSION",
23 "lib/bullet.rb",
24 "lib/bullet/association.rb",
25 "lib/bullet/logger.rb",
26 "lib/bulletware.rb",
27 "lib/hack/active_record.rb",
28 "rails/init.rb",
29 "spec/bullet_association_spec.rb",
30 "spec/spec.opts",
31 "spec/spec_helper.rb",
32 "tasks/bullet_tasks.rake"
33 ]
34 s.homepage = %q{http://www.huangzhimin.com/projects/4-bullet}
35 s.rdoc_options = ["--charset=UTF-8"]
36 s.require_paths = ["lib"]
37 s.rubygems_version = %q{1.3.5}
38 s.summary = %q{A plugin to kill N+1 queries and unused eager loading}
39 s.test_files = [
40 "spec/spec_helper.rb",
41 "spec/bullet_association_spec.rb"
42 ]
43
44 if s.respond_to? :specification_version then
45 current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
46 s.specification_version = 3
47
48 if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
49 else
50 end
51 else
52 end
53 end
Something went wrong with that request. Please try again.