Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Upgrade metadata table to v4.0 fails on Derby #1265

Closed
azalesky opened this issue Apr 1, 2016 · 1 comment
Closed

Upgrade metadata table to v4.0 fails on Derby #1265

azalesky opened this issue Apr 1, 2016 · 1 comment

Comments

@azalesky
Copy link
Contributor

@azalesky azalesky commented Apr 1, 2016

What version of Flyway are you using?

4.0

What database are you using (type & version)?

Apache Derby 10.10.2.0 - (1582446)

What operating system are you using?

CentOS7

What did you do?

I try to switch from v3.2.1 to v4.0

What did you expect to see?

Metadata table should be altered on first migrate call

What did you see instead?

Error code 30000, SQL state 42X01: Syntax error: Encountered "NOT" at line 1, column 69.

azalesky added a commit to azalesky/flyway that referenced this issue Apr 1, 2016
azalesky added a commit to azalesky/flyway that referenced this issue Apr 1, 2016
@axelfontaine axelfontaine added this to the Flyway 4.0.1 milestone Apr 18, 2016
axelfontaine added a commit to flyway/flywaydb.org that referenced this issue Apr 18, 2016
axelfontaine added a commit to flyway/flywaydb.org that referenced this issue Apr 18, 2016
@axelfontaine
Copy link
Contributor

@axelfontaine axelfontaine commented Apr 18, 2016

Thanks for the fix! Merged.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants