Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Make Gradle 3.0 the new minimum supported version #1429

Closed
djohnsonmach opened this issue Sep 12, 2016 · 2 comments
Closed

Make Gradle 3.0 the new minimum supported version #1429

djohnsonmach opened this issue Sep 12, 2016 · 2 comments

Comments

@djohnsonmach
Copy link

@djohnsonmach djohnsonmach commented Sep 12, 2016

What version of Flyway are you using?

4.0.3 (also tried 4.0.2)

Which client are you using? (Command-line, Java API, Maven plugin, Gradle plugin, SBT plugin, ANT tasks)

Gradle plugin

What database are you using (type & version)?

MySQL 5.6.27

What operating system are you using?

MacOS X

What did you do?

(Please include the content causing the issue, any relevant configuration settings, and the command you ran)

Created a custom Gradle task in the buildSrc directory that extends AbstractFlywayTask with Gradle 3.0. (Works fine in Gradle 2.13). I created a sample project to duplicate the issue, which can be found here: Gradle 3.0/FlywayDB 4.0.3 Issue

Ran the command:

./gradlew build

What did you expect to see?

Expected to be able to perform a Gradle build, including database migrations.

What did you see instead?

The build fails with an exception:

Dustins-MBP:gradle-flywaydb-issue djohnson$ ./gradlew build
Listening for transport dt_socket at address: 5006
:buildSrc:compileJava UP-TO-DATE
:buildSrc:compileGroovy FAILED

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':compileGroovy'.
> Unable to load class org.flywaydb.gradle.task.AbstractFlywayTask due to missing dependency org/gradle/api/internal/DynamicObject
@djohnsonmach
Copy link
Author

@djohnsonmach djohnsonmach commented Sep 12, 2016

From the same issue posted on the Gradle forums, it appears the solution may be to simply release another version using Gradle 3 to clear up the bytecode incompatibiility:

https://discuss.gradle.org/t/missing-dependency-org-gradle-api-internal-dynamicobject-prevents-extending-plugin-task/19472/2

@axelfontaine axelfontaine added this to the Flyway 5.0.0 milestone Nov 27, 2017
@axelfontaine axelfontaine changed the title Unable to create custom Gradle task extending AbstractFlywayTask with Gradle 3.0/FlywayDB 4.0.3 Make Gradle 3.0 the new minimum supported version Nov 30, 2017
axelfontaine added a commit to flyway/flywaydb.org that referenced this issue Nov 30, 2017
@axelfontaine
Copy link
Contributor

@axelfontaine axelfontaine commented Nov 30, 2017

We have now bumped the minimum supported Gradle version to 3.0 as part of the Flyway 5.0 release.

axelfontaine added a commit to flyway/flywaydb.org that referenced this issue Nov 30, 2017
dohrayme pushed a commit to dohrayme/flyway that referenced this issue Feb 3, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.