Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Flyway 5.2.2 incorrectly complains about required SQLite upgrade #2221

Closed
la-urre opened this issue Nov 28, 2018 · 2 comments
Closed

Flyway 5.2.2 incorrectly complains about required SQLite upgrade #2221

la-urre opened this issue Nov 28, 2018 · 2 comments

Comments

@la-urre
Copy link

@la-urre la-urre commented Nov 28, 2018

Which version and edition of Flyway are you using?

I am trying to migrate from 5.2.1 to 5.2.2 or 5.2.3

If this is not the latest version, can you reproduce the issue with the latest one as well?

(Many bugs are fixed in newer releases and upgrading will often resolve the issue)
Yes with 5.2.3

Which client are you using? (Command-line, Java API, Maven plugin, Gradle plugin)

Gradle plugin

Which database are you using (type & version)?

Sqlite 3.16.1

Which operating system are you using?

Windows 7

What did you do?

(Please include the content causing the issue, any relevant configuration settings, the SQL statement that failed (if relevant) and the command you ran.)
I changed the dependency in my build.gradle from 5.2.1 to 5.2.2, then I relaunched my project.
I already have a dependency to org.xerial:sqlite-jdbc:3.16.1 that I left untouched

What did you expect to see?

I expect Flyway to continue accepting my version of Sqlite as it's a minor release

What did you see instead?

I got the following error: "SQLite upgrade required: SQLite 3.0 is outdated and no longer supported by Flyway. Flyway currently supports SQLite 3.7.2 and newer."

@axelfontaine
Copy link
Contributor

@axelfontaine axelfontaine commented Nov 28, 2018

Thanks for reporting. Definitely a regression. Will be fixed in the next point release.

@axelfontaine axelfontaine changed the title Issue with 5.2.2: "SQLite upgrade required: SQLite 3.0 is outdated and no longer supported by Flyway. Flyway currently supports SQLite 3.7.2 and newer." Flyway 5.2.2 incorrectly complains about required SQLite upgrade Nov 28, 2018
@axelfontaine
Copy link
Contributor

@axelfontaine axelfontaine commented Nov 30, 2018

Further investigation revealed this to be a bug in older Xerial JDBC drivers that incorrectly report the current SQLite version. We added a workaround to compensate for this. Upgrading the driver also fixes the issue with Flyway 5.2.3.

axelfontaine added a commit to flyway/flywaydb.org that referenced this issue Nov 30, 2018
axelfontaine added a commit that referenced this issue Nov 30, 2018
dohrayme pushed a commit to dohrayme/flyway that referenced this issue Feb 3, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants