Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Snowflake 4.1.1 support #2645

Closed
filiprichtarik opened this issue Jan 28, 2020 · 3 comments
Closed

Snowflake 4.1.1 support #2645

filiprichtarik opened this issue Jan 28, 2020 · 3 comments

Comments

@filiprichtarik
Copy link

@filiprichtarik filiprichtarik commented Jan 28, 2020

Which version and edition of Flyway are you using?

Flyway Community Edition 6.2.0

Which client are you using? (Command-line, Java API, Maven plugin, Gradle plugin)

Command line

Which database are you using (type & version)?

Snowflake 4.1.1

Which operating system are you using?

Linux

What did you do?

Last week Snowflake updated our databases and we are getting warning to upgrade flyway to support latest Snowflake. But there is no newer version to use than 6.2.0,

major version has changed so it triggers following recommendation:

recommendFlywayUpgradeIfNecessaryForMajorVersion("3.50");

@juliahayward
Copy link
Member

@juliahayward juliahayward commented Jan 28, 2020

The recommendation is (or at least should be) just a warning; do you see any failure running against Snowflake 4? We will run our tests against the latest Snowflake asap and change the recommendation accordingly.

@juliahayward juliahayward added this to the Flyway 6.2.1 milestone Jan 28, 2020
@filiprichtarik
Copy link
Author

@filiprichtarik filiprichtarik commented Jan 29, 2020

no issue so far, meanwhile jumped to Snowflake 4.2 and still everything ok (at least our use cases)

@MikielAgutu MikielAgutu removed this from the Flyway 6.2.1 milestone Jan 30, 2020
@MikielAgutu MikielAgutu added this to the Flyway 6.x milestone Jan 30, 2020
@juliahayward
Copy link
Member

@juliahayward juliahayward commented Feb 3, 2020

All the tests are green with 4.2 so fine to go ahead and ignore the warning. Flyway 6.2.2 will have the check updated.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Development

No branches or pull requests

3 participants