Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Unable to decrease block depth below 0 error in version 6.2.4 #2689

Closed
goranpaues opened this issue Feb 26, 2020 · 0 comments
Closed

Unable to decrease block depth below 0 error in version 6.2.4 #2689

goranpaues opened this issue Feb 26, 2020 · 0 comments
Assignees
Milestone

Comments

@goranpaues
Copy link

@goranpaues goranpaues commented Feb 26, 2020

Which version and edition of Flyway are you using?

6.2.4

If this is not the latest version, can you reproduce the issue with the latest one as well?

(Many bugs are fixed in newer releases and upgrading will often resolve the issue)
Yes

Which client are you using? (Command-line, Java API, Maven plugin, Gradle plugin)

Command-line

Which database are you using (type & version)?

Oracle 18c Express Edition

Which operating system are you using?

Windows (Powershell)

What did you do?

I upgraded to latest Flyway version and was running "flyway migrate" on our database and the repeatable migration attached failed. This statement has been successfully processed in older Flyway version (5.0.7)

What did you expect to see?

That that attached repeatable migration was successfully processed.

What did you see instead?

Migrating schema "TDSYS" with repeatable migration JOB EMAIL PKG ADMIN
ERROR: Unable to parse statement in .\Source\admin\packages\R___JOB_EMAIL_PKG_BODY_ADMIN.sql at line 1 col 1: Flyway par
sing bug: unable to decrease block depth below 0

R___JOB_EMAIL_PKG_BODY_ADMIN.zip

@Lyeeedar Lyeeedar self-assigned this Feb 26, 2020
@Lyeeedar Lyeeedar added this to the Flyway 6.3 milestone Feb 28, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Development

No branches or pull requests

2 participants