Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fixes #2193: PostgreSQL 11.0 is not supported (clean() fails) #2194

Merged

Conversation

@tinybarks
Copy link
Contributor

@tinybarks tinybarks commented Nov 4, 2018

Fixes #2193.

I don't see any other changes in PostgreSQL 11.0 that would break compatibility, but please check before merging.

@axelfontaine
Copy link
Contributor

@axelfontaine axelfontaine commented Nov 5, 2018

Thanks for the pull request! Truly appreciated. This will be integrated in 6.0.

@ieugen
Copy link

@ieugen ieugen commented Nov 6, 2018

Hi,

Why not back port-it to the 5.x branch? The fix seems simple. I've also checked the issues for 6.x and it doesn't look like it will be released very soon. Any ETA for that?
/Eugen

@axelfontaine
Copy link
Contributor

@axelfontaine axelfontaine commented Nov 6, 2018

@ieugen Support for new database versions is only added in major and minor releases, not patch releases. Until 6.0.0 is released, you can simply build Flyway from source to get it.

@ieugen
Copy link

@ieugen ieugen commented Nov 7, 2018

Ok. Thnks for explaining.

@axelfontaine axelfontaine merged commit c09aa43 into flyway:master Nov 27, 2018
1 of 2 checks passed
1 of 2 checks passed
continuous-integration/travis-ci/pr The Travis CI build is in progress
Details
license/cla Contributor License Agreement is signed.
Details
@axelfontaine
Copy link
Contributor

@axelfontaine axelfontaine commented Nov 29, 2018

Thank you very much once again for the pull request! Merged. I have also added you to the hall of fame page. (flyway-6.0.0 branch until release)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

3 participants