Skip to content
No description, website, or topics provided.
Branch: master
Clone or download
plribeiro3000 Merge pull request #6 from voxik/fog2x-compat
Fix compatibility with fog-core 2.x.
Latest commit 4f8d1f3 Mar 7, 2019
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
docs Add PDF versions of CLAs. May 21, 2014
examples Fix compatibility with fog-core 2.x. Mar 7, 2019
gemfiles Removes unused dependencies Jun 26, 2014
lib/fog Fix compatibility with fog-core 2.x. Mar 7, 2019
spec/fog/compute Fix compatibility with fog-core 2.x. Mar 7, 2019
tests Fix compatibility with fog-core 2.x. Mar 7, 2019
.editorconfig Keep file formatting consistent Jan 14, 2016
.gitignore
.travis.yml Update bundler gem on travis before running tests. Feb 18, 2016
CHANGELOG.md Bump to version 1.1.0 Feb 19, 2016
CONTRIBUTING.md
CONTRIBUTORS.md
Gemfile Fix paths and get tests working. May 13, 2014
LICENSE.txt Initial commit breaking out fog-softlayer from fog metarepo. May 9, 2014
README.md Use the SVG gem version badge Mar 4, 2017
Rakefile
fog-softlayer.gemspec Fix .gemspec file to properly load class. Mar 7, 2019

README.md

fog-softlayer - SoftLayer module for fog.

Gem Version Build Status Dependency Status

This gem is a module for the fog gem that allows you to manage resources in the SoftLayer Cloud.

It is included by the main fog metagem but can used as an independent library in other applications.

Currently supported services:

  • Compute
  • Storage
  • DNS
  • Network

Additional services coming soon:

  • CDN
  • Load Balancer
  • Message Queue

Installation

Add this line to your application's Gemfile:

gem "fog-softlayer"

And then execute:

$ bundle

Or install it yourself as:

$ gem install fog-softlayer

Usage

See examples/

Contributing

See CONTRIBUTING.md

You can’t perform that action at this time.