Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 72 lines (60 sloc) 3.123 kB
711a914 update rakefile and add gemspec
Wesley Beary authored
1 Gem::Specification.new do |s|
e78c44e @geemus convert to rakegem
geemus authored
2 s.specification_version = 2 if s.respond_to? :specification_version=
711a914 update rakefile and add gemspec
Wesley Beary authored
3 s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
e78c44e @geemus convert to rakegem
geemus authored
4
5 ## Leave these as is they will be modified for you by the rake gemspec task.
6 ## If your rubyforge_project name is different, then edit it and comment out
7 ## the sub! line in the Rakefile
b968cf8 @geemus [gogrid] cleanup
geemus authored
8 s.name = 'fog'
2e57e20 @geemus Release 1.5.0
geemus authored
9 s.version = '1.5.0'
10 s.date = '2012-07-28'
e78c44e @geemus convert to rakegem
geemus authored
11 s.rubyforge_project = 'fog'
12
9d1e801 @rupakg Add new HP providers for Object Storage, Compute and CDN services.
rupakg authored
13
e78c44e @geemus convert to rakegem
geemus authored
14 ## Make sure your summary is short. The description may be as long
15 ## as you like.
16 s.summary = "brings clouds to you"
0cadbbb @watsonian Update gemspec description to mention popular services that are suppo…
watsonian authored
17 s.description = "The Ruby cloud services library. Supports all major cloud providers including AWS, Rackspace, Linode, Blue Box, StormOnDemand, and many others. Full support for most AWS services including EC2, S3, CloudWatch, SimpleDB, ELB, and RDS."
e78c44e @geemus convert to rakegem
geemus authored
18
19 ## List the primary authors. If there are a bunch of authors, it's probably
20 ## better to set the email to an email list or something. If you don't have
21 ## a custom homepage, consider using your GitHub URL or the like.
22 s.authors = ["geemus (Wesley Beary)"]
23 s.email = 'geemus@gmail.com'
e3dfde8 @geemus [docs] update links to point to http://github.com/fog/fog
geemus authored
24 s.homepage = 'http://github.com/fog/fog'
e78c44e @geemus convert to rakegem
geemus authored
25
26 ## This sections is only necessary if you have C extensions.
27 # s.require_paths << 'ext'
28 # s.extensions = %w[ext/extconf.rb]
29
9d1e801 @rupakg Add new HP providers for Object Storage, Compute and CDN services.
rupakg authored
30 ## This gets added to the $LOAD_PATH so that 'lib/NAME.rb' can be required as
31 ## require 'NAME.rb' or'/lib/NAME/file.rb' can be as require 'NAME/file.rb'
32 s.require_paths = %w[lib]
33
e78c44e @geemus convert to rakegem
geemus authored
34 ## If your gem includes any executables, list them here.
9480e3e Version bump to 0.0.12
Wesley Beary authored
35 s.executables = ["fog"]
e78c44e @geemus convert to rakegem
geemus authored
36
37 ## Specify any RDoc options here. You'll want to add your README and
38 ## LICENSE files to the extra_rdoc_files list.
711a914 update rakefile and add gemspec
Wesley Beary authored
39 s.rdoc_options = ["--charset=UTF-8"]
df3a068 @miketheman As discussed in #991, this converts the readme from SimpleMarkup to M…
miketheman authored
40 s.extra_rdoc_files = %w[README.md]
711a914 update rakefile and add gemspec
Wesley Beary authored
41
e78c44e @geemus convert to rakegem
geemus authored
42 ## List your runtime dependencies here. Runtime dependencies are those
43 ## that are needed for an end user to actually USE your code.
29d95e5 @geemus bump dependency versions
geemus authored
44 s.add_dependency('builder')
00734a6 @kevmoo Default to being less pessimistic about excon
kevmoo authored
45 s.add_dependency('excon', '~>0.14')
8923984 @geemus [misc] update gem deps to latest/greatest
geemus authored
46 s.add_dependency('formatador', '~>0.2.0')
dcefc2d @nirvdrum Fixed #875: Loosen multi_json version.
nirvdrum authored
47 s.add_dependency('multi_json', '~>1.0')
e78c44e @geemus convert to rakegem
geemus authored
48 s.add_dependency('mime-types')
e2a0c1a @geemus [misc] loosen dependencies to avoid conflicts
geemus authored
49 s.add_dependency('net-scp', '~>1.0.4')
a468aa9 @geemus [core] loosen net-ssh dependency to avoid chef conflict
geemus authored
50 s.add_dependency('net-ssh', '>=2.1.3')
8923984 @geemus [misc] update gem deps to latest/greatest
geemus authored
51 s.add_dependency('nokogiri', '~>1.5.0')
7aec7fe @geemus fall back to ruby-hmac when openssl refuses to sha256
geemus authored
52 s.add_dependency('ruby-hmac')
711a914 update rakefile and add gemspec
Wesley Beary authored
53
e78c44e @geemus convert to rakegem
geemus authored
54 ## List your development dependencies here. Development dependencies are
55 ## those that are only needed during development
8790513 @geemus add jekyll to dev deps (for building docs)
geemus authored
56 s.add_development_dependency('jekyll')
99289a4 @mitchellh Update bundler to use gemspec, modify Rakefile to use bundler environ…
mitchellh authored
57 s.add_development_dependency('rake')
df36b45 @geemus [vsphere|compute] test fixes
geemus authored
58 s.add_development_dependency('rbvmomi')
b9aa00d @geemus [misc] fix deprecated rdoc rake tasks
geemus authored
59 s.add_development_dependency('rdoc')
543e629 @ohadlevy adding required gem to run the tests
ohadlevy authored
60 s.add_development_dependency('thor')
e2a0c1a @geemus [misc] loosen dependencies to avoid conflicts
geemus authored
61 s.add_development_dependency('rspec', '~>1.3.1')
ade4888 @abenari new rbovirt version
abenari authored
62 s.add_development_dependency('rbovirt', '>=0.0.11')
e2a0c1a @geemus [misc] loosen dependencies to avoid conflicts
geemus authored
63 s.add_development_dependency('shindo', '~>0.3.4')
ecb9ec8 Update to the latest VirtualBox gem while we're at it for good measure
Mark A. Miller authored
64 s.add_development_dependency('virtualbox', '~>0.9.1')
2972c69 Move fission from reg dependency to dev dependency per comments on pu…
Michael Brodhead & Shai Rosenfeld authored
65 s.add_development_dependency('fission')
7cf6031 @Keoven [openstack|compute] Add Tenants and Fix Authentication Implementation
Keoven authored
66 s.add_development_dependency('pry')
b2c8ff0 @geemus [core] work toward separate requires
geemus authored
67 # s.add_development_dependency('ruby-libvirt','~>0.4.0')
e78c44e @geemus convert to rakegem
geemus authored
68
ec6e901 @geemus [gemspec] fix file list, now buildable from source
geemus authored
69 s.files = `git ls-files`.split("\n")
70 s.test_files = `git ls-files -- {spec,tests}/*`.split("\n")
e78c44e @geemus convert to rakegem
geemus authored
71 end
Something went wrong with that request. Please try again.