New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Use OpenSSL::Digest instead of deprecated OpenSSL::Digest::Digest #2473

Merged
merged 1 commit into from Dec 11, 2013

Conversation

Projects
None yet
3 participants
@amatsuda
Copy link
Contributor

amatsuda commented Dec 11, 2013

OpenSSL::Digest::Digest has been discouraged to use from very ancient era such as Ruby 1.8 https://github.com/ruby/ruby/blob/ruby_1_8_7/ext/openssl/lib/openssl/digest.rb#L51
and finally was deprecated recently. ruby/ruby#446

@coveralls

This comment has been minimized.

Copy link

coveralls commented Dec 11, 2013

Coverage Status

Coverage increased (+2.09%) to 69.15% when pulling 7000546 on amatsuda:digest_digest into d89564e on fog:master.

@geemus

This comment has been minimized.

Copy link
Member

geemus commented Dec 11, 2013

@amatsuda - thanks!

geemus added a commit that referenced this pull request Dec 11, 2013

Merge pull request #2473 from amatsuda/digest_digest
Use OpenSSL::Digest instead of deprecated OpenSSL::Digest::Digest

@geemus geemus merged commit bb16b38 into fog:master Dec 11, 2013

1 check passed

default The Travis CI build passed
Details

@capen capen referenced this pull request Jan 23, 2014

Closed

update fog to 1.19.0 #221

@artemas artemas referenced this pull request Nov 27, 2015

Closed

Update fog gem #1569

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment