Skip to content
FogLAMP "modbus" South plugin: a Modbus south plugin that supports modbus-tcp and modbus-rtu connections
Branch: develop
Clone or download
Singhal-Vaibhav Merge pull request #34 from foglamp/master
 v1.6.0 release - master to develop
Latest commit 2d1beaf May 23, 2019
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
doc FOGL-2758 Fix typos and incorrect error message Apr 25, 2019
include FOGL-2729 Addition of support for 32 bit (and beyond) values from Apr 16, 2019
packages/Debian FOGL-2771 Add Coral package May 21, 2019
.gitignore
CMakeLists.txt FOGL-2834: foglamp-south-modbus-c make fails on RHEL instance (#30) May 17, 2019
Description FOGL-2774 Addition of RPM package files May 10, 2019
FindFogLAMP.cmake
LICENSE Update LICENSE Jan 4, 2019
Package FOGL-2834: foglamp-south-modbus-c make fails on RHEL instance (#30) May 17, 2019
README.rst FOGL-2729 Addition of support for 32 bit (and beyond) values from Apr 16, 2019
VERSION
foglamp.version VERSION changed May 22, 2019
make_deb FOGL-2771 Add Coral package May 21, 2019
mkversion FOGL-2338 External VERSION file Jan 23, 2019
modbus_south.cpp FOGL-2758 Fix typos and incorrect error message Apr 25, 2019
plugin.cpp
requirements.sh FOGL-2839 Add in sudo for apt and yum May 20, 2019

README.rst

Modbus C/C++ South plugin

Installation

This modbus plugin supports modbus-tcp and modbus-rtu. and it requires the Linux libmodbus library, this can be installed with given requirements.sh or the following steps:

$ sudo apt install -y libmodbus-dev

Build

To build Modbus C++ plugin run the commands:

$ mkdir build
$ cd build
$ cmake ..
$ make
  • By default the FogLAMP develop package header files and libraries are expected to be located in /usr/include/foglamp and /usr/lib/foglamp
  • If FOGLAMP_ROOT env var is set and no -D options are set, the header files and libraries paths are pulled from the ones under the FOGLAMP_ROOT directory. Please note that you must first run 'make' in the FOGLAMP_ROOT directory.

You may also pass one or more of the following options to cmake to override this default behaviour:

  • FOGLAMP_SRC sets the path of a FogLAMP source tree
  • FOGLAMP_INCLUDE sets the path to FogLAMP header files
  • FOGLAMP_LIB sets the path to FogLAMP libraries
  • FOGLAMP_INSTALL sets the installation path of Random plugin
NOTE:
  • The FOGLAMP_INCLUDE option should point to a location where all the FogLAMP header files have been installed in a single directory.
  • The FOGLAMP_LIB option should point to a location where all the FogLAMP libraries have been installed in a single directory.
  • 'make install' target is defined only when FOGLAMP_INSTALL is set

Examples:

  • no options

    $ cmake ..

  • no options and FOGLAMP_ROOT set

    $ export FOGLAMP_ROOT=/some_foglamp_setup

    $ cmake ..

  • set FOGLAMP_SRC

    $ cmake -DFOGLAMP_SRC=/home/source/develop/FogLAMP ..

  • set FOGLAMP_INCLUDE

    $ cmake -DFOGLAMP_INCLUDE=/dev-package/include ..

  • set FOGLAMP_LIB

    $ cmake -DFOGLAMP_LIB=/home/dev/package/lib ..

  • set FOGLAMP_INSTALL

    $ cmake -DFOGLAMP_INSTALL=/home/source/develop/FogLAMP

    $ cmake -DFOGLAMP_INSTALL=/usr/local/foglamp

Packaging for 'modbusc' south

This repo contains the scripts used to create a foglamp-south-modbusc Debian package.

The make_deb script

Run the make_deb command after installing libmodbus-dev:

$ ./make_deb help
make_deb [help|clean|cleanall]
This script is used to create the Debian package of FoglAMP C++ 'modbusc' south plugin
Arguments:
 help     - Display this help text
 clean    - Remove all the old versions saved in format .XXXX
 cleanall - Remove all the versions, including the last one
$

Building a Package

Finally, run the make_deb command:

$ ./make_deb
The package root directory is   : /home/ubuntu/source/foglamp-south-modbus-c
The FogLAMP required version    : >=1.4
The package will be built in    : /home/ubuntu/source/foglamp-south-modbus-c/packages/build
The architecture is set as      : x86_64
The package name is             : foglamp-south-modbusc-1.0.0-x86_64

Populating the package and updating version file...Done.
Building the new package...
dpkg-deb: building package 'foglamp-south-modbusc' in 'foglamp-south-modbusc-1.0.0-x86_64.deb'.
Building Complete.
$

Cleaning the Package Folder

Use the clean option to remove all the old packages and the files used to make the package.

Use the cleanall option to remove all the packages and the files used to make the package.

You can’t perform that action at this time.