[Deprecated]
Switch branches/tags
Nothing to show
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
lib
test
tools
.gitignore
.hgignore
.npmignore
.travis.yml
LICENCE
Makefile
README.md
jsdoc.conf.json
package.json

README.md

core.arity

Build Status NPM version Dependencies Status stable

Restricts the arity of variadic functions.

Example

var arity = require('core.arity')

[1, -1, 2, -3].reduce(arity.binary(Math.max), 0)
// => 2

Installing

The easiest way is to grab it from NPM. If you're running in a Browser environment, you can use Browserify

$ npm install core.arity

Using with CommonJS

If you're not using NPM, Download the latest release, and require the core.arity.umd.js file:

var arity = require('core.arity')

Using with AMD

Download the latest release, and require the core.arity.umd.js file:

require(['core.arity'], function(arity) {
  ( ... )
})

Using without modules

Download the latest release, and load the core.arity.umd.js file. The properties are exposed in the global folktale.core.arity object:

<script src="/path/to/core.arity.umd.js"></script>

Compiling from source

If you want to compile this library from the source, you'll need Git, Make, Node.js, and run the following commands:

$ git clone git://github.com/folktale/core.arity.git
$ cd core.arity
$ npm install
$ make bundle

This will generate the dist/core.arity.umd.js file, which you can load in any JavaScript environment.

Documentation

You can read the documentation online or build it yourself:

$ git clone git://github.com/folktale/core.arity.git
$ cd core.arity
$ npm install
$ make documentation

Then open the file docs/index.html in your browser.

Platform support

This library assumes an ES5 environment, but can be easily supported in ES3 platforms by the use of shims. Just include es5-shim :)

Licence

Copyright (c) 2014 Quildreen Motta.

Released under the MIT licence.