New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Unable to open FontForge after updating to latest version on Mac OSX 10.10.5 #2530

Closed
appajid opened this Issue Oct 15, 2015 · 7 comments

Comments

Projects
None yet
7 participants
@appajid

appajid commented Oct 15, 2015

After updating to FontForge 2015-08-24 I'm unable to open FontForge in Mac OSX 10.10.5. After opening X11, I tried opening FontForge.. it's icon is just jumping for a while and after that no window opens. No sign of any app opened. Earlier I used to see a new untitled font opened in fontforge. Now there is no activity..

@nguyenchiencong

This comment has been minimized.

nguyenchiencong commented Oct 15, 2015

+1

@eject-it

This comment has been minimized.

eject-it commented Oct 15, 2015

won't run here either. Neither the binary nor the self compiled source. Does it have some self test? I can launch it from the command line so I assume it did build alright.

@pszalko

This comment has been minimized.

pszalko commented Oct 18, 2015

+1

@weiweihuanghuang

This comment has been minimized.

weiweihuanghuang commented Oct 18, 2015

Same problem:

OS X 10.10.5, FF 2015-08-24, XQuartz 2.7.8 (xorg-server 1.16.4)

Process:               fontforge [8187]
Path:                  /Applications/FontForge.app/Contents/Resources/opt/local/bin/fontforge
Identifier:            fontforge
Version:               ???
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           fontforge [8187]
User ID:               501

Date/Time:             2015-10-18 12:03:12.114 +0200
OS Version:            Mac OS X 10.10.5 (14F27)
Report Version:        11
Anonymous UUID:        449C6753-9055-E38F-6948-9EF67597C811

Sleep/Wake UUID:       E1CF3C17-1E94-4DA0-8131-660AF5E57AEC

Time Awake Since Boot: 35000 seconds
Time Since Wake:       2900 seconds

Crashed Thread:        0

Exception Type:        EXC_BREAKPOINT (SIGTRAP)
Exception Codes:       0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
  Library not loaded: /opt/local/lib/libjpeg.9.dylib
  Referenced from: /Applications/FontForge.app/Contents/Resources/opt/local/bin/fontforge
  Reason: image not found

Binary Images:
    0x7fff67f87000 -     0x7fff67fbd887  dyld (353.2.3) <B1B370A5-479F-3533-8AD7-97B687D4F989> /usr/lib/dyld
    0x7fff889dc000 -     0x7fff889dcfff  com.apple.Cocoa (6.8 - 21) <EAC0EA1E-3C62-3B28-A941-5D8B1E085FF8> /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa
    0x7fff8c6f5000 -     0x7fff8c6f5fff  com.apple.CoreServices (62 - 62) <C69DA8A7-B536-34BF-A93F-1C170E2C6D58> /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices
@weiweihuanghuang

This comment has been minimized.

weiweihuanghuang commented Oct 18, 2015

@reyneke-vosz

This comment has been minimized.

reyneke-vosz commented Oct 20, 2015

I had the same issue under 10.9. and the head version helped me, too. Thanks weiweihuanghuang

@jtanx

This comment has been minimized.

Contributor

jtanx commented Aug 26, 2016

Fairly certain the latest (20160404) release works - reopen if not.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment