New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[1.3.10] SVG Favicon doesn't show in Firefox #2879

Closed
foosel opened this Issue Nov 8, 2018 · 4 comments

Comments

2 participants
@foosel
Owner

foosel commented Nov 8, 2018

Problem

Firefox doesn't show the new SVG Favicon:

image

According to this comment and this link this seems to be due to the used mime type. Doesn't seem to be the mime type, that's already set to image/svg+xml.

@foosel

This comment has been minimized.

Owner

foosel commented Nov 8, 2018

Correct mime type is already set, favicon still doesn't show up. Investigating...

foosel added a commit that referenced this issue Nov 8, 2018

Give the favicon mask SVG width and height attrs
Otherwise it won't render correctly in Firefox due to drawImage silently
failing, see also https://bugzilla.mozilla.org/show_bug.cgi?id=700533

Closes #2879

@foosel foosel added the status:solved label Nov 8, 2018

@foosel

This comment has been minimized.

Owner

foosel commented Nov 8, 2018

Fixed by the above commit. The issue was actually that drawing a SVG to a canvas used internally fails silently in Firefox if the SVG doesn't have width and height attributes. Simply adding those solved the issue immediately.

Pushed and ready for 1.3.10rc2

@ThaliaFromPrussia

This comment has been minimized.

ThaliaFromPrussia commented Nov 9, 2018

Thank you!

@foosel

This comment has been minimized.

Owner

foosel commented Nov 13, 2018

1.3.10rc2 was just released.

@foosel foosel closed this Nov 13, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment