Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Octoprint crashes upon resuming print #3213

Closed
diyengineer opened this issue Jul 2, 2019 · 4 comments

Comments

@diyengineer
Copy link

commented Jul 2, 2019

-->

What were you doing?

While printing, clicking pause, results in a normal pause. When "resume" is pressed the entire octoprint crashes (goes offline).

  1. Start a print.
  2. Click on pause after its begun
  3. Once its time to resume click resume
  4. See error as print server goes offline.

What did you expect to happen?

Expected to pause a print, and go through my normal resume routine. Instead it resumed, and the octoprint server crashed. Repeated across 2 printers multiple times, all result in same problem.

What happened instead?

octoprint server crashed and doesn't really appear to record in either of the log file what happened.

Did the same happen when running OctoPrint in safe mode?

Will try first thing tomorrow.

Version of OctoPrint

1.3.11

Operating System running OctoPrint

.16

Printer model & used firmware incl. version

Solidoodle press + Marlin flavor

Browser and version of browser, operating system running browser

Windows 10, Chrome
octoprint (2).log
octoprint (1).log
serial.log1.txt
serial.log.2.txt

Link to octoprint.log

Attached

Link to contents of terminal tab or serial.log

Attached

Link to contents of Javascript console in the browser

Screenshot(s)/video(s) showing the problem:

I have read the FAQ.

@foosel

This comment has been minimized.

Copy link
Owner

commented Jul 2, 2019

Did the same happen when running OctoPrint in safe mode?

Will try first thing tomorrow.

Please report back when this is clarified. It doesn't make sense to look into an issue if it's not verified that it's reproducible with stock OctoPrint.

Also please clarify what "crashes" means. Is the process gone (ps -ef | grep -i octoprint returns nothing but the grep) or does the server just stop responding?

Try running it manually from SSH:

sudo service octoprint stop
~/oprint/bin/octoprint serve --safemode

This will start the server in your SSH session. It will log to the console (you can stop it again by hitting Ctrl+C). Reproduce the issue and check if it logs any kind of segfault or error that never made it into the log. Share the results.

@diyengineer

This comment has been minimized.

Copy link
Author

commented Jul 3, 2019

Foosel,

We tested 3 machines in safe mode (5 prints on each), and the problem vanished! We flashed the card and installed a new copy, ran perfect without safe mode! As soon as we installed:

https://plugins.octoprint.org/plugins/filamentencore/

The problem came right back once the plugin was installed. It pauses as intended, but as soon as "resume" is clicked this appears and i have to power cycle the printer.
server offline

I will try your instructions and report back tomorrow:

@foosel

This comment has been minimized.

Copy link
Owner

commented Jul 3, 2019

Hm, that sounds like there's an issue with this particular plugin then. I'm going to close this ticket, however it would still make sense to run the tests (as you have planned anyhow) and report your findings in the ticket on the plugin's tracker that you already opened (👍).

I'll also disable the plugin on the repository for now until this issue is clarified.

@foosel foosel closed this Jul 3, 2019

@coolcheat

This comment has been minimized.

Copy link

commented Jul 28, 2019

Just thought I'd chime in, I'm a frequent user of filament sensor encore and have never had a crash when resuming / pausing...

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
4 participants
You can’t perform that action at this time.