New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

First Mission: Contributors Page #13

Open
coni2k opened this Issue Mar 13, 2018 · 4 comments

Comments

Projects
None yet
2 participants
@coni2k
Contributor

coni2k commented Mar 13, 2018

This is an experimental attempt to help you to get familiar with our project and make your first pull request.

Follow this tutorial on our wiki to get started:
https://github.com/forCrowd/Backbone/wiki/First-Mission

@jackrataty

This comment has been minimized.

Contributor

jackrataty commented Mar 17, 2018

I am at the point where I installed AngularClient on npm. When I tried to start Angular Client on npm, I got the following error message.

Node could not find a binding for your current environment: Windows 64-bit with Node.js 8x

Found bindings for the following environments: Windows-64 bit with Node. js 5.x

It says, " Run 'npm rebuild node-sass --force' to build the binding for your current environment

then it gave me a list of modules I needed to build a binding for

What should I do now? I'm not sure what that means.

I have a very dated programming background. I have not programmed since the 90s.
Thank you for your help.

@coni2k

This comment has been minimized.

Contributor

coni2k commented Mar 17, 2018

Hi @jackrataty,

Thank you for your interest in our project.

First, could you please tell me what your node & npm versions? You can see them by running these commands on command console:

node -v

(Should be v9.8.0)

npm -v

(Should be 5.6.0+)

@jackrataty

This comment has been minimized.

Contributor

jackrataty commented Mar 17, 2018

node v.8.10.0
npm 5.6.0

downloading correct version. Thank you!

@coni2k

This comment has been minimized.

Contributor

coni2k commented Mar 17, 2018

Great, let me know whether this works.

I tried to reproduce the error but it's not happening on my machine. Hopefully this solves it. Else, you can check this link from stackoverflow:
https://stackoverflow.com/questions/37986800/node-sass-could-not-find-a-binding-for-your-current-environment

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment