Track outdated npm dependencies.
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
.circleci
bin
lib
src
test
.babelrc
.editorconfig
.eslintrc
.gitattributes
.gitignore
.release-it.json
.vile.yml
CHANGELOG.md
CODE_OF_CONDUCT.md
LICENSE
README.md
coffeelint.json
package-lock.json
package.json

README.md

vile-ncu Circle CI score-badge coverage-badge dependency-badge

A Vile plugin for tracking outdated npm dependencies (via npm-check-updates).

Requirements

Installation

This plugin is already packaged with vile's core lib, but you can also install it manually:

npm i -D vile vile-ncu

Usage

vile a -p ncu

Config

default options

ncu:
  config:
    all: false # --upgradeAll
    path: "package.json"

Known Issues

If you are using yarn you might run into this:

TypeError: log.gauge.isEnabled is not a function

Checkout this open issue at yarnpkg/yarn for some help.

Also trying npm i -D npmlog or npm i -D npm might do the trick.

Versioning

This project uses Semver.

Licensing

This project is licensed under the MPL-2.0 license.

Any contributions made to this project are made under the current license.

Contributions

Current list of Contributors.

Any contributions are welcome and appreciated!

All you need to do is submit a Pull Request.

  1. Please consider tests and code quality before submitting.
  2. Please try to keep commits clean, atomic and well explained (for others).

Issues

Current issue tracker is on GitHub.

Even if you are uncomfortable with code, an issue or question is welcome.

Code Of Conduct

By participating in this project you agree to our Code of Conduct.

Maintainers

Architecture

  • src is es6+ syntax compiled with Babel
  • lib generated js library

Developing

cd vile-ncu
npm install
npm run dev
npm test