Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Cleaned up project to make it easier to maintain and release (based o…

…n bundler gem style)
  • Loading branch information...
commit dc0e884bfdcbf5dd0c768a0dedd990342ebca6b1 1 parent f420e8f
@andrew andrew authored
View
4 .gitignore
@@ -0,0 +1,4 @@
+*.gem
+.bundle
+Gemfile.lock
+pkg/*
View
4 Gemfile
@@ -0,0 +1,4 @@
+source "http://rubygems.org"
+
+# Specify your gem's dependencies in capify-ec2.gemspec
+gemspec
View
2  Rakefile
@@ -0,0 +1,2 @@
+require 'bundler'
+Bundler::GemHelper.install_tasks
View
BIN  capify-ec2-1.gem
Binary file not shown
View
29 capify-ec2.gemspec
@@ -1,18 +1,23 @@
-#-*- encoding: utf-8 -*-
+# -*- encoding: utf-8 -*-
$:.push File.expand_path("../lib", __FILE__)
+require "capify-ec2/version"
Gem::Specification.new do |s|
- s.name = "capify-ec2"
- s.version = "1"
- s.authors = ["Noah Cantor"]
- s.email = "noah.cantor@forward.co.uk"
- s.homepage = "http://www.forward.co.uk"
- s.summary = "Grabs roles from ec2's tags and autogenerates capistrano tasks"
- s.platform = Gem::Platform::RUBY
- s.files = %w(lib).map {|d| Dir.glob("#{d}/**/*")}.flatten << "capify-ec2.gemspec"
- s.require_path = "lib"
- s.has_rdoc = false
+ s.name = "capify-ec2"
+ s.version = Capify::Ec2::VERSION
+ s.platform = Gem::Platform::RUBY
+ s.authors = ["Noah Cantor", "Siddharth Dawara"]
+ s.email = ["noah.cantor@forward.co.uk", "siddharth.dawara@forward.co.uk"]
+ s.homepage = "http://github.com/forward/capify-ec2"
+ s.summary = %q{Grabs roles from ec2's tags and autogenerates capistrano tasks}
+ s.description = %q{Grabs roles from ec2's tags and autogenerates capistrano tasks}
+
+ s.rubyforge_project = "capify-ec2"
+
+ s.files = `git ls-files`.split("\n")
+ s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
+ s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
+ s.require_paths = ["lib"]
s.add_dependency('activesupport', '>= 3.0.0')
s.add_dependency('fog')
end
-
View
5 lib/capify-ec2/version.rb
@@ -0,0 +1,5 @@
+module Capify
+ module Ec2
+ VERSION = "1.0.0"
+ end
+end
Please sign in to comment.
Something went wrong with that request. Please try again.