Skip to content

Fog dependency #34

Closed
piersadrian opened this Issue Jul 3, 2013 · 4 comments

3 participants

@piersadrian

Is there a particular reason fog is locked at 1.3.1 in the gemspec? That version is over a year old and the hard version lock will undoubtedly cause dependency resolution problems for people.

Can the required fog version be bumped up to something more recent, like, say, ~> 1.10.0?

@jalopezcar

I think I have the same problem.

/usr/local/lib/site_ruby/1.9.1/rubygems/specification.rb:1988:in raise_if_conflicts': Unable to activate fog-1.3.1, because net-scp-1.1.2 conflicts with net-scp (~> 1.0.4) (Gem::LoadError)
from /usr/local/lib/site_ruby/1.9.1/rubygems/specification.rb:1161:in
activate'
from /usr/local/lib/site_ruby/1.9.1/rubygems/specification.rb:1197:in block in activate_dependencies'
from /usr/local/lib/site_ruby/1.9.1/rubygems/specification.rb:1183:in
each'
from /usr/local/lib/site_ruby/1.9.1/rubygems/specification.rb:1183:in activate_dependencies'
from /usr/local/lib/site_ruby/1.9.1/rubygems/specification.rb:1165:in
activate'
from /usr/local/lib/site_ruby/1.9.1/rubygems.rb:186:in rescue in try_activate'
from /usr/local/lib/site_ruby/1.9.1/rubygems.rb:183:in
try_activate'
from /usr/local/lib/site_ruby/1.9.1/rubygems/core_ext/kernel_require.rb:115:in rescue in require'
from /usr/local/lib/site_ruby/1.9.1/rubygems/core_ext/kernel_require.rb:122:in
require'
from /usr/lib/ruby/gems/1.9.1/gems/capistrano-2.14.2/lib/capistrano/configuration/loading.rb:152:in require'
from ./app/config/capifony/prod.rb:14:in
load'
from /usr/lib/ruby/gems/1.9.1/gems/capistrano-2.14.2/lib/capistrano/configuration/loading.rb:93:in instance_eval'
from /usr/lib/ruby/gems/1.9.1/gems/capistrano-2.14.2/lib/capistrano/configuration/loading.rb:93:in
load'
from /usr/lib/ruby/gems/1.9.1/gems/capistrano-2.14.2/lib/capistrano/configuration/loading.rb:172:in load_from_file'
from /usr/lib/ruby/gems/1.9.1/gems/capistrano-2.14.2/lib/capistrano/configuration/loading.rb:89:in
load'
from /usr/lib/ruby/gems/1.9.1/gems/capistrano-2.14.2/lib/capistrano/configuration/loading.rb:86:in block in load'
from /usr/lib/ruby/gems/1.9.1/gems/capistrano-2.14.2/lib/capistrano/configuration/loading.rb:86:in
each'
from /usr/lib/ruby/gems/1.9.1/gems/capistrano-2.14.2/lib/capistrano/configuration/loading.rb:86:in load'
from /usr/lib/ruby/gems/1.9.1/gems/capistrano-2.14.2/lib/capistrano/ext/multistage.rb:18:in
block (3 levels) in '
from /usr/lib/ruby/gems/1.9.1/gems/capistrano-2.14.2/lib/capistrano/configuration/execution.rb:138:in instance_eval'
from /usr/lib/ruby/gems/1.9.1/gems/capistrano-2.14.2/lib/capistrano/configuration/execution.rb:138:in
invoke_task_directly'
from /usr/lib/ruby/gems/1.9.1/gems/capistrano-2.14.2/lib/capistrano/configuration/callbacks.rb:25:in invoke_task_directly_with_callbacks'
from /usr/lib/ruby/gems/1.9.1/gems/capistrano-2.14.2/lib/capistrano/configuration/execution.rb:89:in
execute_task'
from /usr/lib/ruby/gems/1.9.1/gems/capistrano-2.14.2/lib/capistrano/configuration/execution.rb:101:in find_and_execute_task'
from /usr/lib/ruby/gems/1.9.1/gems/capistrano-2.14.2/lib/capistrano/cli/execute.rb:46:in
block in execute_requested_actions'
from /usr/lib/ruby/gems/1.9.1/gems/capistrano-2.14.2/lib/capistrano/cli/execute.rb:45:in each'
from /usr/lib/ruby/gems/1.9.1/gems/capistrano-2.14.2/lib/capistrano/cli/execute.rb:45:in
execute_requested_actions'
from /usr/lib/ruby/gems/1.9.1/gems/capistrano-2.14.2/lib/capistrano/cli/help.rb:19:in execute_requested_actions_with_help'
from /usr/lib/ruby/gems/1.9.1/gems/capistrano-2.14.2/lib/capistrano/cli/execute.rb:34:in
execute!'
from /usr/lib/ruby/gems/1.9.1/gems/capistrano-2.14.2/lib/capistrano/cli/execute.rb:14:in execute'
from /usr/lib/ruby/gems/1.9.1/gems/capistrano-2.14.2/bin/cap:4:in
'
from /usr/local/bin/cap:23:in load'
from /usr/local/bin/cap:23:in

'

Any idea how to fix this?

Thanks.

@Rylon
Forward member
Rylon commented Jul 18, 2013

Hey there,

I'm just working on merging some outstanding pull requests and tackling some issues.

How about if I set the version in the gemspec to >= 1.12.0 ?

I'll need to bump it to support IAM Roles for authentication anyway, but I'd rather not have another hard version lock.

Thanks!

@piersadrian

@Rylon for sure. That sounds great, and should be fine for the foreseeable future. This is a seriously great tool, by the way. I can't imagine running my servers without it. Thanks!

@Rylon
Forward member
Rylon commented Jul 18, 2013

Thanks! 😃

@Rylon Rylon closed this in 5ace347 Jul 19, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.