Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
rhythmbox plugin to browse and play radio stations
Python Other
Branch: rb3
Failed to load latest commit information.
po first commit
.gitignore expand search and treeview correctly - issue #5
CHANGELOG derivative copyright changes
COPYING first commit
INSTALL install instructions
LICENSE.txt Add LICENSE file via addalicense.com
Makefile incorporate patch from Andrea Musuruane
README.md Update README.md
board_handler.py project reformat code as recommended by pycharm
feed.py project reformat code as recommended by pycharm
icecast_handler.py project reformat code as recommended by pycharm
install.sh install instructions
local-logo.png first commit
note.png first commit
radio-browser.glade removed warnings and spurious close button
radio-browser.plugin initial conversion to python3
radio-browser.png first commit
radio-browser.py fix for rb3.2 crash - issue #12
radio_browser_source.py fix community board results
radio_station.py project reformat code as recommended by pycharm
radio_station.ui expand search and treeview correctly - issue #5
radiotime_handler.py project reformat code as recommended by pycharm
record_process.py project reformat code as recommended by pycharm
shoutcast-logo.png first commit
shoutcast_handler.py project reformat code as recommended by pycharm
xiph-logo.png first commit

README.md

Radio-Browser

GTK3+ port from original source https://github.com/segler-alex/rhythmbox-radio-browser/issues for Rhythmbox 3.0 and later

GTK3 Author

Flattr Button paypaldonate

pic

Installation

git clone https://github.com/fossfreedom/radio-browser -b rb3
cd radio-browser
./install.sh

For a system wide install then:

git clone https://github.com/fossfreedom/radio-browser -b rb3
cd radio-browser
sudo make install

Then launch rhythmbox and enable the plugin "Internet Radio Browser"

Non-Debian based distros

You will need to install the equivalent packages for your distro: streamripper gir1.2-gconf-2.0

Debian & Ubuntu 14.04 notes:

packages required to be installed:

sudo apt-get install streamripper gir1.2-gconf-2.0
Something went wrong with that request. Please try again.