Permalink
Browse files

Item14605: UpdatesPlugin fails on perl 5.10

  • Loading branch information...
gac410 committed Jan 21, 2018
1 parent 9ae136a commit 25c64351f28e841b7f3564dd229adad9fe87ad9c
Showing with 4 additions and 3 deletions.
  1. +4 −3 UpdatesPlugin/lib/Foswiki/Plugins/UpdatesPlugin.pm
@@ -40,9 +40,10 @@ sub initPlugin {
my $outdatedPlugins;
$outdatedPlugins = $request->cookie("FOSWIKI_UPDATESPLUGIN") unless TRACE;
return 1
if defined($outdatedPlugins)
&& scalar( split( /\s*,\s*/, $outdatedPlugins ) ) <= 0; # 0: DoNothing
if ( defined $outdatedPlugins ) {
my @staleplugins = split( /\s*,\s*/, $outdatedPlugins );
return 1 if scalar(@staleplugins) <= 0;
}
Foswiki::Func::readTemplate("updatesplugin");

0 comments on commit 25c6435

Please sign in to comment.