Permalink
Browse files

Release 4sweep as open source under MIT License.

  • Loading branch information...
4sweep committed Jul 1, 2018
0 parents commit 55d525792e99bb00c734f7075e67348b2e2b605d
Showing 394 changed files with 20,818 additions and 0 deletions.
@@ -0,0 +1,16 @@
# See http://help.github.com/ignore-files/ for more about ignoring files.
#
# If you find yourself ignoring temporary files generated by your text editor
# or operating system, you probably want to add a global ignore instead:
# git config --global core.excludesfile ~/.gitignore_global
# Ignore bundler config
/.bundle
# Ignore the default SQLite database.
/db/*.sqlite3
# Ignore all logfiles and tempfiles.
/log/*.log.*
/log/*.log
/tmp
25 Capfile
@@ -0,0 +1,25 @@
# Load DSL and Setup Up Stages
require 'capistrano/setup'
# Includes default deployment tasks
require 'capistrano/deploy'
# Includes tasks from other gems included in your Gemfile
#
# For documentation on these, see for example:
#
# https://github.com/capistrano/rvm
# https://github.com/capistrano/rbenv
# https://github.com/capistrano/chruby
# https://github.com/capistrano/bundler
# https://github.com/capistrano/rails
#
# require 'capistrano/rvm'
# require 'capistrano/rbenv'
# require 'capistrano/chruby'
require 'capistrano/bundler'
require 'capistrano/rails/assets'
require 'capistrano/rails/migrations'
# Loads custom tasks from `lib/capistrano/tasks' if you have any defined.
Dir.glob('lib/capistrano/tasks/*.cap').each { |r| import r }
83 Gemfile
@@ -0,0 +1,83 @@
source 'https://rubygems.org'
gem 'rails', '~> 3.2'
gem 'bootstrap-sass', '~> 2.3'
# Bundle edge Rails instead:
# gem 'rails', :git => 'git://github.com/rails/rails.git'
gem 'mysql2', '~> 0.3.20'
gem 'rollbar'
gem 'json'
gem 'foursquare2'
gem 'yaml_db'
# gem 'system_timer'
gem 'oauth2'
gem 'settingslogic'
# gem 'chosen-rails'
# gem 'devise'
# gem 'omniauth'
# gem 'omniauth-foursquare'
# gem 'font-awesome-rails'
gem 'compass-rails'
gem 'kaminari'
gem 'bootstrap-kaminari-views'
# gem 'rmagick'
# gem 'aws-s3'
gem 'momentjs-rails'
gem 'delayed_job_active_record'
gem 'daemons'
gem 'bootstrap-datepicker-rails'
# gem 'newrelic_rpm'
gem 'pnotify-rails', '~> 1'
gem 'aws-sdk', '~> 1'
gem 'turnout'
gem 'select2-rails', '~> 3.5'
gem 'underscore-rails'
gem 'delayed_job_recurring'
gem 'net-ssh', '~>2.9.2'
# Gems used only for assets and not required
# in production environments by default.
group :assets do
gem 'jquery-cookie-rails'
gem 'sass', '3.2.14'
gem 'sass-rails', '~> 3.2.3'
gem 'coffee-rails', '~> 3.2.1'
gem 'pegjs', :path => 'vendor/ruby-pegjs'
gem 'fontello_rails_converter', '0.3.3'
gem 'handlebars_assets', '~> 0.18.0'
# See https://github.com/sstephenson/execjs#readme for more supported runtimes
# gem 'therubyracer', :platforms => :ruby
gem 'uglifier'
end
gem 'jquery-rails'
gem 'jquery-ui-rails'
# To use ActiveModel has_secure_password
# gem 'bcrypt-ruby', '~> 3.0.0'
gem 'execjs'
gem "libv8", "= 3.16.14.19"
gem 'therubyracer'
# To use Jbuilder templates for JSON
# gem 'jbuilder'
# Use unicorn as the app server
# gem 'unicorn'
# Deploy with Capistrano
group :development do
gem 'capistrano-rails', '~> 1.1', require: false
gem 'capistrano-bundler', '~> 1.1', require: false
# gem 'coffee-rails-source-maps'
end
# To use debugger
# gem 'debugger'
@@ -0,0 +1,257 @@
PATH
remote: vendor/ruby-pegjs
specs:
pegjs (0.0.1)
GEM
remote: https://rubygems.org/
specs:
actionmailer (3.2.18)
actionpack (= 3.2.18)
mail (~> 2.5.4)
actionpack (3.2.18)
activemodel (= 3.2.18)
activesupport (= 3.2.18)
builder (~> 3.0.0)
erubis (~> 2.7.0)
journey (~> 1.0.4)
rack (~> 1.4.5)
rack-cache (~> 1.2)
rack-test (~> 0.6.1)
sprockets (~> 2.2.1)
activemodel (3.2.18)
activesupport (= 3.2.18)
builder (~> 3.0.0)
activerecord (3.2.18)
activemodel (= 3.2.18)
activesupport (= 3.2.18)
arel (~> 3.0.2)
tzinfo (~> 0.3.29)
activeresource (3.2.18)
activemodel (= 3.2.18)
activesupport (= 3.2.18)
activesupport (3.2.18)
i18n (~> 0.6, >= 0.6.4)
multi_json (~> 1.0)
addressable (2.3.6)
arel (3.0.3)
aws-sdk (1.59.0)
aws-sdk-v1 (= 1.59.0)
aws-sdk-v1 (1.59.0)
json (~> 1.4)
nokogiri (>= 1.4.4)
bootstrap-datepicker-rails (1.3.0.2)
railties (>= 3.0)
bootstrap-kaminari-views (0.0.5)
kaminari (>= 0.13)
rails (>= 3.1)
bootstrap-sass (2.3.2.2)
sass (~> 3.2)
builder (3.0.4)
capistrano (3.2.1)
i18n
rake (>= 10.0.0)
sshkit (~> 1.3)
capistrano-bundler (1.1.3)
capistrano (~> 3.1)
sshkit (~> 1.2)
capistrano-rails (1.1.2)
capistrano (~> 3.1)
capistrano-bundler (~> 1.1)
chunky_png (1.3.3)
coffee-rails (3.2.2)
coffee-script (>= 2.2.0)
railties (~> 3.2.0)
coffee-script (2.3.0)
coffee-script-source
execjs
coffee-script-source (1.8.0)
colorize (0.7.3)
compass (0.12.3)
chunky_png (~> 1.2)
fssm (>= 0.2.7)
sass (= 3.2.14)
compass-rails (2.0.0)
compass (>= 0.12.2)
daemons (1.1.9)
delayed_job (4.0.4)
activesupport (>= 3.0, < 4.2)
delayed_job_active_record (4.0.2)
activerecord (>= 3.0, < 4.2)
delayed_job (>= 3.0, < 4.1)
erubis (2.7.0)
execjs (2.2.2)
faraday (0.9.0)
multipart-post (>= 1.2, < 3)
faraday_middleware (0.9.1)
faraday (>= 0.7.4, < 0.10)
fontello_rails_converter (0.3.2)
launchy
rest-client
rubyzip (~> 1.0)
foursquare2 (2.0.1)
faraday (~> 0.8)
faraday_middleware (>= 0.8)
hashie (>= 1.0, < 3.0.0)
fssm (0.2.10)
handlebars_assets (0.18)
execjs (>= 1.2.9)
multi_json
sprockets (>= 2.0.3)
tilt
hashie (2.1.2)
hike (1.2.3)
i18n (0.6.11)
journey (1.0.4)
jquery-cookie-rails (1.3.1.1)
railties (>= 3.2.0, < 5.0)
jquery-rails (3.1.2)
railties (>= 3.0, < 5.0)
thor (>= 0.14, < 2.0)
jquery-ui-rails (5.0.2)
railties (>= 3.2.16)
json (1.8.1)
jwt (1.0.0)
kaminari (0.16.1)
actionpack (>= 3.0.0)
activesupport (>= 3.0.0)
launchy (2.4.3)
addressable (~> 2.3)
libv8 (3.16.14.7)
mail (2.5.4)
mime-types (~> 1.16)
treetop (~> 1.4.8)
mime-types (1.25.1)
mini_portile (0.6.1)
momentjs-rails (2.8.3)
railties (>= 3.1)
multi_json (1.10.1)
multi_xml (0.5.5)
multipart-post (2.0.0)
mysql2 (0.3.17)
net-scp (1.2.1)
net-ssh (>= 2.6.5)
net-ssh (2.9.1)
netrc (0.8.0)
nokogiri (1.6.4.1)
mini_portile (~> 0.6.0)
oauth2 (1.0.0)
faraday (>= 0.8, < 0.10)
jwt (~> 1.0)
multi_json (~> 1.3)
multi_xml (~> 0.5)
rack (~> 1.2)
pnotify-rails (1.2.2)
polyglot (0.3.5)
rack (1.4.5)
rack-accept (0.4.5)
rack (>= 0.4)
rack-cache (1.2)
rack (>= 0.4)
rack-ssl (1.3.4)
rack
rack-test (0.6.2)
rack (>= 1.0)
rails (3.2.18)
actionmailer (= 3.2.18)
actionpack (= 3.2.18)
activerecord (= 3.2.18)
activeresource (= 3.2.18)
activesupport (= 3.2.18)
bundler (~> 1.0)
railties (= 3.2.18)
railties (3.2.18)
actionpack (= 3.2.18)
activesupport (= 3.2.18)
rack-ssl (~> 1.3.2)
rake (>= 0.8.7)
rdoc (~> 3.4)
thor (>= 0.14.6, < 2.0)
rake (10.3.2)
rdoc (3.12.2)
json (~> 1.4)
ref (1.0.5)
rest-client (1.7.2)
mime-types (>= 1.16, < 3.0)
netrc (~> 0.7)
rmagick (2.13.3)
rollbar (1.2.8)
multi_json (~> 1.3)
rubyzip (1.1.6)
sass (3.2.14)
sass-rails (3.2.6)
railties (~> 3.2.0)
sass (>= 3.1.10)
tilt (~> 1.3)
select2-rails (3.5.9.1)
thor (~> 0.14)
settingslogic (2.0.9)
sprockets (2.2.3)
hike (~> 1.2)
multi_json (~> 1.0)
rack (~> 1.0)
tilt (~> 1.1, != 1.3.0)
sshkit (1.5.1)
colorize
net-scp (>= 1.1.2)
net-ssh (>= 2.8.0)
therubyracer (0.12.1)
libv8 (~> 3.16.14.0)
ref
thor (0.19.1)
tilt (1.4.1)
treetop (1.4.15)
polyglot
polyglot (>= 0.3.1)
turnout (2.0.1)
rack (~> 1.3)
rack-accept (~> 0.4)
tzinfo (0.3.42)
uglifier (2.5.3)
execjs (>= 0.3.0)
json (>= 1.8.0)
underscore-rails (1.7.0)
yaml_db (0.3.0)
rails (>= 3.0, < 4.3)
rake (>= 0.8.7)
PLATFORMS
ruby
DEPENDENCIES
aws-sdk
bootstrap-datepicker-rails
bootstrap-kaminari-views
bootstrap-sass (~> 2.3)
capistrano-bundler (~> 1.1)
capistrano-rails (~> 1.1)
coffee-rails (~> 3.2.1)
compass-rails
daemons
delayed_job_active_record
execjs
fontello_rails_converter
foursquare2
handlebars_assets
jquery-cookie-rails
jquery-rails
jquery-ui-rails
json
kaminari
momentjs-rails
mysql2
oauth2
pegjs!
pnotify-rails (~> 1)
rails (= 3.2.18)
rmagick
rollbar
sass (= 3.2.14)
sass-rails (~> 3.2.3)
select2-rails
settingslogic
therubyracer
turnout
uglifier
underscore-rails
yaml_db
Oops, something went wrong.

0 comments on commit 55d5257

Please sign in to comment.