Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

1.1.7 release

  • Loading branch information...
commit 1143cf3b132ad6df534c37f68d05147e8f9eea42 1 parent 307e4bc
@jliszka jliszka authored
Showing with 10 additions and 3 deletions.
  1. +5 −0 CHANGELOG.md
  2. +4 −2 README.md
  3. +1 −1  build.sbt
View
5 CHANGELOG.md
@@ -1,5 +1,10 @@
## Release Notes
+# 1.1.7
+
+- support for EnumField and EnumNameField
+- added explicit lift jar dependencies to build.sbt
+
# 1.1.6
- iteratee support
View
6 README.md
@@ -37,7 +37,7 @@ Because Rogue is designed to work with several versions of lift-mongodb-record (
you'll want to declare your dependency on Rogue as `intransitive` and declare an explicit dependency
on the version of Lift you want to target. In sbt, that would look like the following:
- val rogue = "com.foursquare" %% "rogue" % "1.1.6" intransitive()
+ val rogue = "com.foursquare" %% "rogue" % "1.1.7" intransitive()
val liftMongoRecord = "net.liftweb" %% "lift-mongodb-record" % "2.4-M2"
You can substitute "2.4-M2" for whatever version of Lift you are using. Rogue has been used in
@@ -87,10 +87,12 @@ for "findAndModify" query objects
## Releases
-The latest release is 1.1.6. See the [changelog](https://github.com/foursquare/rogue/blob/master/CHANGELOG.md) for more details.
+The latest release is 1.1.7. See the [changelog](https://github.com/foursquare/rogue/blob/master/CHANGELOG.md) for more details.
New since 1.1.0:
+- support for EnumField and EnumNameField
+- added explicit lift jar dependencies to build.sbt
- iteratee support
- default WriteConcern is configurable
- renamed blockingBulkDelete_!! to bulkDelete_!! (takes a WriteConcern)
View
2  build.sbt
@@ -1,6 +1,6 @@
name := "rogue"
-version := "1.1.7-SNAPSHOT"
+version := "1.1.7"
organization := "com.foursquare"
Please sign in to comment.
Something went wrong with that request. Please try again.