Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

2.0.0-beta22 release (huge thanks to mattpap!)

  • Loading branch information...
commit 8c367be230be6157ce598a107dc320550bdd7903 1 parent d194668
@jliszka jliszka authored
Showing with 11 additions and 5 deletions.
  1. +6 −0 CHANGELOG.md
  2. +4 −4 README.md
  3. +1 −1  project/RogueBuild.scala
View
6 CHANGELOG.md
@@ -1,5 +1,11 @@
## Release Notes
+# 2.0.0-beta22
+
+- support for scala 2.9.2 and 2.10.0 (mattpap)
+- support for Model.distinct(_.field) (mattpap)
+- sbt 0.12.0 (mattpap)
+
# 2.0.0-beta21
- fix signatures for $or queries
View
8 README.md
@@ -37,13 +37,13 @@ Because Rogue is designed to work with several versions of lift-mongodb-record (
you'll want to declare your dependency on Rogue as `intransitive` and declare an explicit dependency
on the version of Lift you want to target. In sbt, that would look like the following:
- val rogueField = "com.foursquare" %% "rogue-field" % "2.0.0-beta21" intransitive()
- val rogueCore = "com.foursquare" %% "rogue-core" % "2.0.0-beta21" intransitive()
- val rogueLift = "com.foursquare" %% "rogue-lift" % "2.0.0-beta21" intransitive()
+ val rogueField = "com.foursquare" %% "rogue-field" % "2.0.0-beta22" intransitive()
+ val rogueCore = "com.foursquare" %% "rogue-core" % "2.0.0-beta22" intransitive()
+ val rogueLift = "com.foursquare" %% "rogue-lift" % "2.0.0-beta22" intransitive()
val liftMongoRecord = "net.liftweb" %% "lift-mongodb-record" % "2.4-M5"
You can substitute "2.4-M2" for whatever version of Lift you are using. Rogue has been used in
-production against Lift 2.2 and 2.4-M2. If you encounter problems using Rogue with other versions
+production against Lift 2.2 and 2.4-M5. If you encounter problems using Rogue with other versions
of Lift, please let us know.
Join the [rogue-users google group](http://groups.google.com/group/rogue-users) for help, bug reports,
View
2  project/RogueBuild.scala
@@ -14,7 +14,7 @@ object RogueBuild extends Build {
lazy val lift = Project("rogue-lift", file("rogue-lift/")) dependsOn(core % "compile;test->test;runtime->runtime")
lazy val defaultSettings: Seq[Setting[_]] = Seq(
- version := "2.0.0-beta22-SNAPSHOT",
+ version := "2.0.0-beta22",
organization := "com.foursquare",
crossScalaVersions := Seq("2.9.1", "2.9.2", "2.10.0", "2.9.0-1", "2.9.0"),
publishMavenStyle := true,
Please sign in to comment.
Something went wrong with that request. Please try again.