transformers 0.4 #217

Closed
snoyberg opened this Issue May 5, 2014 · 16 comments

Projects

None yet

10 participants

@snoyberg
Member
snoyberg commented May 5, 2014

This'll take a while...

BlogLiterately-0.7.1.6 (Brent Yorgey byorgey@gmail.com) cannot use:

  • transformers-0.4.0.0 -- ==0.3.*

Glob-0.7.4 (michael@snoyman.com) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

HaTeX-3.10.0.0 (Daniel D��az dhelta.diaz@gmail.com) cannot use:

  • transformers-0.4.0.0 -- >=0.2.2 && <0.4

JuicyPixels-3.1.5.1 (Brent Yorgey byorgey@gmail.com @Twinside) cannot use:

  • transformers-0.4.0.0 -- >=0.2.2 && <0.4

MonadCatchIO-transformers-0.3.1.0 (FP Complete michael@fpcomplete.com) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

ad-4.2.0.1 (Edward Kmett ekmett@gmail.com @ekmett) cannot use:

  • transformers-0.4.0.0 -- ==0.3.*

adjunctions-4.0.3 (Edward Kmett ekmett@gmail.com @ekmett) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

aws-0.9 (FP Complete michael@fpcomplete.com @aristidb) cannot use:

  • transformers-0.4.0.0 -- >=0.2.2.0 && <0.4

blaze-builder-enumerator-0.2.0.5 (Adam Bergmark adam@bergmark.nl @meiersi) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

bound-1.0.2 (Edward Kmett ekmett@gmail.com @ekmett) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

bytes-0.14 (Edward Kmett ekmett@gmail.com @analytics) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

comonad-4.0.1 (Edward Kmett ekmett@gmail.com @ekmett) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

comonad-extras-4.0 (Edward Kmett ekmett@gmail.com @ekmett) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

conduit-1.1.1.1 (michael@snoyman.com @snoyberg) cannot use:

  • transformers-0.4.0.0 -- >=0.2.2 && <0.4

contravariant-0.5 (Edward Kmett ekmett@gmail.com @ekmett) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

data-lens-2.10.4 (Roman Cheplyaka roma@ro-che.info @roconnor) cannot use:

  • transformers-0.4.0.0 -- >=0.2.0 && <0.4

derive-2.5.15 (FP Complete michael@fpcomplete.com @ndmitchell) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

diagrams-builder-0.5.0.9 (Brent Yorgey byorgey@gmail.com @diagrams) cannot use:

  • transformers-0.4.0.0 -- ==0.3.*

distributive-0.4.3.2 (Edward Kmett ekmett@gmail.com @ekmett) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

either-4.1.1 (Edward Kmett ekmett@gmail.com @ekmett) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

errors-1.4.6 (Adam Bergmark adam@bergmark.nl @Gabriel439) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

exceptions-0.5 (Stefan Wehr wehr@factisresearch.com @ekmett) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

failure-0.2.0.2 (John Wiegley) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

fay-0.20.0.0 (Adam Bergmark adam@bergmark.nl @faylang) cannot use:

  • transformers-0.4.0.0 -- ==0.3.*

fclabels-1.1.7.1 (Ryan Newton ryan.newton@alum.mit.edu @sebastiaanvisser) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

foldl-1.0.3 (michael@snoyman.com @Gabriel439) cannot use:

  • transformers-0.4.0.0 -- >=0.2.0.0 && <0.4

free-4.7.1 (Edward Kmett ekmett@gmail.com @ekmett) cannot use:

  • transformers-0.4.0.0 -- >=0.2.0 && <0.4

graphs-0.5.0.1 (Edward Kmett ekmett@gmail.com @ekmett) cannot use:

  • transformers-0.4.0.0 -- >=0.2.2 && <0.4

hashable-extras-0.2 (Edward Kmett ekmett@gmail.com @analytics) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

heist-0.13.1 (Adam Bergmark adam@bergmark.nl @snapframework) cannot use:

  • transformers-0.4.0.0 -- ==0.3.*

hspec-meta-1.8.3 (Simon Hengel sol@typeful.net @hspec) cannot use:

  • transformers-0.4.0.0 -- >=0.2.2.0 && <0.4.0

io-streams-1.1.4.3 (FP Complete michael@fpcomplete.com @snapframework) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

kan-extensions-4.0.2 (Edward Kmett ekmett@gmail.com @ekmett) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

keys-3.10 (Edward Kmett ekmett@gmail.com @ekmett) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

lifted-base-0.2.2.1 (michael@snoyman.com @basvandijk) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

linear-1.10.1.1 (Edward Kmett ekmett@gmail.com @ekmett) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

machines-0.2.5 (Edward Kmett ekmett@gmail.com @ekmett) cannot use:

  • transformers-0.4.0.0 -- ==0.3.*

mmorph-1.0.2 (michael@snoyman.com @Gabriel439) cannot use:

  • transformers-0.4.0.0 -- >=0.2.0.0 && <0.4

monad-control-0.3.2.3 (michael@snoyman.com @basvandijk) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

monad-coroutine-0.8 (Mario Blazevic blamario@yahoo.com) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

monad-parallel-0.7.1.2 (Mario Blazevic blamario@yahoo.com) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

monad-st-0.2.3 (Edward Kmett ekmett@gmail.com @ekmett) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

monadic-arrays-0.2.1.3 (Edward Kmett ekmett@gmail.com @ekmett) cannot use:

  • transformers-0.4.0.0 -- >=0.2.0 && <0.4

mtl-2.1.3.1 (Edward Kmett ekmett@gmail.com @ekmett) cannot use:

  • transformers-0.4.0.0 -- ==0.3.*

optparse-applicative-0.8.0.1 (michael@snoyman.com @pcapriotti) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

parsers-0.11 (Edward Kmett ekmett@gmail.com @ekmett) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

persistent-template-1.3.1.3 (FP Complete michael@fpcomplete.com) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

pipes-4.1.1 (Gabriel Gonzalez Gabriel439@gmail.com @Gabriel439) cannot use:

  • transformers-0.4.0.0 -- >=0.2.0.0 && <0.4

pipes-parse-3.0.1 (Gabriel Gonzalez Gabriel439@gmail.com @Gabriel439) cannot use:

  • transformers-0.4.0.0 -- >=0.2.0.0 && <0.4

pointed-4.0 (Edward Kmett ekmett@gmail.com @ekmett) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

profunctors-4.0.3 (Edward Kmett ekmett@gmail.com @ekmett) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

reducers-3.10.2 (Edward Kmett ekmett@gmail.com @ekmett) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

resourcet-1.1.2 (michael@snoyman.com @snoyberg) cannot use:

  • transformers-0.4.0.0 -- >=0.2.2 && <0.4

semigroupoids-4.0.1 (Edward Kmett ekmett@gmail.com @ekmett) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

snap-0.13.2.4 (FP Complete michael@fpcomplete.com @snapframework) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

snaplet-fay-0.3.3.5 (Adam Bergmark adam@bergmark.nl @faylang) cannot use:

  • transformers-0.4.0.0 -- ==0.3.*

speculation-1.5.0.1 (Edward Kmett ekmett@gmail.com @ekmett) cannot use:

  • transformers-0.4.0.0 -- >=0.2.2.0 && <0.4

statestack-0.2 (Brent Yorgey byorgey@gmail.com) cannot use:

  • transformers-0.4.0.0 -- ==0.3.*

stm-conduit-2.4.0 (John Wiegley @wowus) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <=0.4

these-0.4.2 (John Wiegley @isomorphism) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

threepenny-gui-0.4.1.0 (FP Complete michael@fpcomplete.com) cannot use:

  • transformers-0.4.0.0 -- ==0.3.*

wai-extra-2.1.1.1 (michael@snoyman.com @yesodweb) cannot use:

  • transformers-0.4.0.0 -- >=0.2.2 && <0.4

wai-test-2.0.1.2 (michael@snoyman.com) cannot use:

  • transformers-0.4.0.0 -- >=0.2.2 && <0.4

wai-websockets-2.1.0.1 (michael@snoyman.com @yesodweb) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

wl-pprint-terminfo-3.7.1 (Edward Kmett ekmett@gmail.com @ekmett) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

xml-conduit-1.2.0.1 (michael@snoyman.com @snoyberg) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4

yaml-0.8.8.2 (michael@snoyman.com @snoyberg) cannot use:

  • transformers-0.4.0.0 -- >=0.1 && <0.4

yesod-1.2.5.2 (michael@snoyman.com @yesodweb) cannot use:

  • transformers-0.4.0.0 -- >=0.2.2 && <0.4

yesod-auth-fb-1.6.2.1 (Felipe Lessa felipe.lessa@gmail.com @meteficha) cannot use:

  • transformers-0.4.0.0 -- >=0.1.3 && <0.4

yesod-core-1.2.15 (michael@snoyman.com @yesodweb) cannot use:

  • transformers-0.4.0.0 -- >=0.2.2 && <0.4

yesod-persistent-1.2.2.3 (michael@snoyman.com @yesodweb) cannot use:

  • transformers-0.4.0.0 -- >=0.2.2 && <0.4

zlib-enum-0.2.3 (Adam Bergmark adam@bergmark.nl @maltem) cannot use:

  • transformers-0.4.0.0 -- >=0.2 && <0.4
@snoyberg snoyberg added a commit that referenced this issue May 5, 2014
@snoyberg snoyberg Upper bounds for #217 12f0e64
@ekmett
Contributor
ekmett commented May 5, 2014

Vincent,

Tickets here get attribute to whomever added a package that depended on
them to hackage not the actual package author, since that is the package
that 'broke stackage' not the original author who never signed up to
maintain it here. =)

You can get it to notify you directly by editing the stackage config to add
yourself as the maintainer of whatever package it is in question. Then
notifications will go to you, not Brent.

-Edward

On Mon, May 5, 2014 at 5:36 PM, Vincent notifications@github.com wrote:

Herm, my name is not Brent Yorgey, thank you very much.


Reply to this email directly or view it on GitHubhttps://github.com/fpco/stackage/issues/217#issuecomment-42164984
.

@Daniel-Diaz
Contributor

Dependency updated in HaTeX (Daniel-Diaz/HaTeX@a50f7ea). The change will reach Hackage in one or (at most) two days.

@ndmitchell
Contributor

derive-2.5.16 released with no upper bound on transformers.

@ekmett
Contributor
ekmett commented May 5, 2014

Starting at the top:

mtl and transformers-compat are updated.

contravariant, distributive and comonad are updated. Though, I'll eventually want to switch instances in comonad to the new transformers style.

Lots to go.

@basvandijk

The following updates have been released:

@Twinside
Contributor
Twinside commented May 6, 2014

@ekmett Thanks for the clarification.

JuicyPixels has been updated

@bergmark
Member
bergmark commented May 8, 2014

fay-0.20.0.1 allows transformers >= 0.3 && < 0.4 || > 0.4.1 && < 0.5
snaplet-fay depends on ekmett/exceptions#31

@bergmark
Member

And snaplet-fay-0.3.3.6

@bergmark bergmark referenced this issue in maltem/zlib-enum May 16, 2014
Merged

Allow transformers == 0.4.* #9

@Gabriel439
Contributor

Alright, I believe that all my packages are completely upgraded. The following packages now build against transformers-0.4.*:

  • errors-1.4.7
  • foldl-1.0.4
  • mmorph-1.0.3
  • pipes-4.1.2
  • pipes-parse-3.0.2
@bergmark
Member

zlib-enum-0.2.3.1

@byorgey
Contributor
byorgey commented Sep 18, 2014

BlogLiterately, diagrams-builder, and statestack were all updated a while ago, sorry I forgot to comment here.

@danclien

Is there an easy way to see what libraries are still incompatible with transformers-0.4?

I ran stackage select without the addRange on transformers and temporarily removed HandsomeSoup soup temporarily, and it seemed to work.

@danclien

Thanks, @Gabriel439.

I manually cross-referenced this list and reverse and came up with this list:

@ekmett
Contributor
ekmett commented Oct 15, 2014

I'm apparently the person dragging my heels the most.

I'll see what I can do to remedy that.

On Wed, Oct 15, 2014 at 5:48 PM, Dan Lien notifications@github.com wrote:

Thanks, @Gabriel439 https://github.com/Gabriel439.

I manually cross-referenced this list and reverse and came up with this
list:


Reply to this email directly or view it on GitHub
#217 (comment).

@bergmark bergmark referenced this issue in silkapp/rest Oct 26, 2014
Closed

Use ExceptT instead of ErrorT #78

@snoyberg
Member

Closing this, it will come up again under GHC 7.10 issues.

@snoyberg snoyberg closed this Dec 31, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment