New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

raspiBackup requires perl #27

Closed
wemsras opened this Issue Nov 24, 2017 · 5 comments

Comments

Projects
None yet
2 participants
@wemsras
Copy link

wemsras commented Nov 24, 2017

Please check if perl installed. If perl is not installed, then you get empty lines with no information. There is no error message. You only see blank lines. I think of testing for perl in the begining of the script like the check for BASH. Tested on VoidLinux for Raspberry Pi.

@wemsras wemsras changed the title RaspiBackup cannot run withour perl RaspiBackup cannot run without perl Nov 24, 2017

@framps

This comment has been minimized.

Copy link
Owner

framps commented Nov 24, 2017

Good catch 👍 I will either add a check for perl of even remove the perl dependency.

@framps framps self-assigned this Nov 24, 2017

@framps framps added the bug label Nov 24, 2017

@framps

This comment has been minimized.

Copy link
Owner

framps commented Nov 24, 2017

raspiBackup will not depend on perl any more in next release. I cherry-picked the fix in https://github.com/framps/raspiBackup/tree/detect_mountpoint. Please verify.

@wemsras

This comment has been minimized.

Copy link
Author

wemsras commented Nov 24, 2017

Yeah. Good job.
i have removed perl an after that i run the raspiBackup.sh (Hotfix Version) without problems.
Thank you.
rbwoperl.txt

@framps

This comment has been minimized.

Copy link
Owner

framps commented Nov 24, 2017

Great. 👍 Will merge the fix into master for next version.

@framps framps changed the title RaspiBackup cannot run without perl raspiBackup requires perl Mar 10, 2018

@framps

This comment has been minimized.

@framps framps closed this Mar 10, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment