Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Fetching contributors…

Cannot retrieve contributors at this time

100 lines (64 sloc) 3.581 kB

Suspenders is a base Rails application that you can upgrade.

Suspenders boy

Installation

First install the suspenders gem:

gem install suspenders

Then run:

suspenders create projectname

This will create a Rails 3.1 app in `projectname'. This script creates a new new git repository. It is not meant to be used against an existing repo.

Suspenders uses Trout to make it easier to maintain a base version of special files like Gemfile and Procfile in Suspenders.

Whenever you want to get the latest and greatest Suspenders' Gemfile, run:

trout update Gemfile

Gemfile

To see the latest and greatest gems, look at Suspenders' template/trout/Gemfile, which will be copied into your projectname/Gemfile.

It includes application gems like:

And testing gems like:

Other goodies

Suspenders also comes with:

  • jQuery for Javascript pleasantry
  • Rails' flashes set up and in application layout.
  • A few nice time formats.

See template/files to see what is generated one-time.

Dependencies

Some gems included in Suspenders have native extensions. You should have GCC installed on your machine before running Suspenders.

If you're running OS X, we recommend the GCC OSX installer.

We use Capybara Webkit for full-stack Javascript integration testing. It requires you have QT installed on your machine before running Suspenders.

Instructions for installing QT on most systems are available here.

Issues

If you have problems, please create a Github issue.

Contributing

Please see CONTRIBUTING.md for details.

Credits

thoughtbot

Suspenders is maintained and funded by thoughtbot, inc

The names and logos for thoughtbot are trademarks of thoughtbot, inc.

License

Suspenders is Copyright © 2008-2011 thoughtbot. It is free software, and may be redistributed under the terms specified in the LICENSE file.

Jump to Line
Something went wrong with that request. Please try again.