Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse code

- remove an obsoleted dependency on py-numarray;

- limiting python version to 2.x only (because py-numpy isn't python3
aware yet);

- eliminating PYTHON_SITELIBDIR in matplotlib dependency.

Submitted by:	rm


git-svn-id: svn+ssh://svn.freebsd.org/ports/head@309962 aed309b6-a8cd-e111-996c-001c23d10e55
  • Loading branch information...
commit cda9106a08e6199c3e2d9630454d4fb198837316 1 parent 9377ad2
authored January 05, 2013

Showing 1 changed file with 5 additions and 6 deletions. Show diff stats Hide diff stats

  1. 11  science/gnudatalanguage/Makefile
11  science/gnudatalanguage/Makefile
@@ -3,6 +3,7 @@
3 3
 
4 4
 PORTNAME=	gnudatalanguage
5 5
 DISTVERSION=	0.9.3
  6
+PORTREVISION=	1
6 7
 CATEGORIES=	science lang
7 8
 MASTER_SITES=	SF/${PORTNAME}/gdl/${DISTVERSION}
8 9
 .if defined(BUILD_PYTHON_MODULE)
@@ -81,12 +82,10 @@ CONFIGURE_ARGS+=--with-hdf=no
81 82
 .endif
82 83
 
83 84
 .if !defined(WITHOUT_PYTHON) || defined(BUILD_PYTHON_MODULE)
84  
-USE_PYTHON=	2.5+
85  
-BUILD_DEPENDS+=	${PYTHON_SITELIBDIR}/numarray:${PORTSDIR}/math/py-numarray \
86  
-		${PYNUMPY}
87  
-RUN_DEPENDS+=	${PYTHON_SITELIBDIR}/numarray:${PORTSDIR}/math/py-numarray \
88  
-		${PYNUMPY} \
89  
-		${PYTHON_SITELIBDIR}/matplotlib:${PORTSDIR}/math/py-matplotlib
  85
+USE_PYTHON=	-2.7
  86
+BUILD_DEPENDS+=	${PYNUMPY}
  87
+RUN_DEPENDS+=	${PYNUMPY} \
  88
+		${PYTHON_PKGNAMEPREFIX}matplotlib>0:${PORTSDIR}/math/py-matplotlib
90 89
 CONFIGURE_ENV+=	PYTHON_VERSION=${_PYTHON_VERSION}
91 90
 CONFIGURE_ARGS+=--with-python=${PYTHONBASE}
92 91
 .else

0 notes on commit cda9106

Please sign in to comment.
Something went wrong with that request. Please try again.