Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Web client development #184

Closed
mcicolella opened this issue Oct 2, 2016 · 4 comments

Comments

@mcicolella
Copy link
Contributor

commented Oct 2, 2016

This is only a container for other issues.
We are developing a web client in Polymer and every part of it has its own repository but this is the most viewed and represents a landing page for developers.

The prototype is already included in the last release.
After starting Freedomotic go to http://localhost:8090 (admin/admin for credentials).

If you want to contribute take a look at
https://github.com/freedomotic/fd-polymer-webapp
https://github.com/freedomotic/fd-polymer-generics
https://github.com/freedomotic/fd-polymer-api-settings
https://github.com/freedomotic/fd-polymer-environments
https://github.com/freedomotic/fd-polymer-ws-service

and leave a comment here if you want to apply.

@P3trur0

This comment has been minimized.

Copy link
Contributor

commented Nov 10, 2016

@mcicolella did you consider React for web client development?

@mcicolella

This comment has been minimized.

Copy link
Contributor Author

commented Nov 10, 2016

@P3trur0 No. Our web developers decided to use Polymer.

@P3trur0

This comment has been minimized.

Copy link
Contributor

commented Nov 10, 2016

@amenak77

This comment has been minimized.

Copy link

commented Nov 10, 2016

Hi all,
about web app test I noticed a problem, the same with Freedomotic itself; when you reduce to icon web app browser's window and change events in freedomotic jfrontend, GUI's changings aren't shown immediately after browser's window pop up. The desync usually ends when you create a new event on web app map. The same happen during jfrontend (aka freedomotic) "iconization" but in a worse way. I call this bug "mr freeze" and afflicts the framework from many years. My pc configuration: Intel Icore 3 1.70 Ghz, RAM 4 Gbytes win 10. Do you have same problems with other OS? My test: run freedomotic and open web app with chrome. I almost forgot: I have a similar problem also when notebook's energy saving utility begin to play. Have a nice evening, Alberto

@mcicolella mcicolella closed this Oct 11, 2017
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.