Permalink
Browse files

Change to use postcss rather than myth

  • Loading branch information...
1 parent 8a7e6d3 commit 68d3bccb32bfa6878c94c6011a3c5c53b60e2585 @emersonveenstra emersonveenstra committed Jun 24, 2016
Showing with 29 additions and 3 deletions.
  1. +1 −0 .gitignore
  2. +2 −1 .travis.yml
  3. +2 −1 README.md
  4. +1 −1 config/build.yml
  5. +19 −0 package.json
  6. +4 −0 postcss.json
View
@@ -5,3 +5,4 @@ out/
*/*/.DS_Store
*/*/*/.DS_Store
env/
+node_modules/
View
@@ -7,8 +7,9 @@ before_install:
- . $HOME/.nvm/nvm.sh
- nvm install 5.7.0
- nvm use 5.7.0
-- npm install myth
+- npm install postcss-cli
- npm install svgo
+- npm install
- openssl aes-256-cbc -K $encrypted_ac880c30010f_key -iv $encrypted_ac880c30010f_iv
-in deploy/key1.enc -out deploy/key1 -d && chmod go-rwx deploy/key1 || true
- openssl aes-256-cbc -K $encrypted_2bfadd9dc6b8_key -iv $encrypted_2bfadd9dc6b8_iv
View
@@ -8,7 +8,8 @@ A shiny replacement for http://freenode.net.
You'll need our node.js dependencies:
```console
-$ sudo npm install -g myth svgo
+$ sudo npm install -g postcss-cli svgo
+$ npm install
```
Then, assuming a Python 3.4 (or later) installation:
View
@@ -16,6 +16,6 @@
output: out/static/img
recursive: True
pattern: '*.svg'
-- command: [myth, --compress, --]
+- command: [postcss, -c, postcss.json]
source: static/css
output: out/static/css
View
@@ -0,0 +1,19 @@
+{
+ "name": "web-7.0",
+ "version": "0.0.1",
+ "description": "Website for http://freenode.net",
+ "repository": {
+ "type": "git",
+ "url": "git+https://github.com/freenode/web-7.0.git"
+ },
+ "author": "",
+ "license": "CC-BY-NC-SA",
+ "bugs": {
+ "url": "https://github.com/freenode/web-7.0/issues"
+ },
+ "homepage": "http://freenode.net",
+ "devDependencies": {
+ "postcss-cssnext": "^2.6.0",
+ "postcss-csso": "^1.1.2"
+ }
+}
View
@@ -0,0 +1,4 @@
+{
+ "use": ["postcss-cssnext", "postcss-csso"],
+ "local-plugins": true
+}

0 comments on commit 68d3bcc

Please sign in to comment.