New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Request for preserving the gw_mode over upgrades #1196

Closed
jerix777 opened this Issue Jul 24, 2017 · 3 comments

Comments

Projects
None yet
3 participants
@jerix777

jerix777 commented Jul 24, 2017

gw-mode is not preserved on sysupgrade.

@mweinelt

This comment has been minimized.

Show comment
Hide comment
@mweinelt

mweinelt Jul 24, 2017

Contributor

Gluon blocks traffic from Mesh to WAN by default, batman's gateway mode isn't the only thing in your custom setup, is it?

Contributor

mweinelt commented Jul 24, 2017

Gluon blocks traffic from Mesh to WAN by default, batman's gateway mode isn't the only thing in your custom setup, is it?

@jerix777

This comment has been minimized.

Show comment
Hide comment
@jerix777

jerix777 Jul 24, 2017

No, it's not the only. I've try to have a special config mode too with these requirements on .
So i've set gw_mode to server in order to set the node as a uplink for others in mesh.
But, after a sysupgrade, gluon reset this value to client breaking down the internet connection for all mesh network...
I've set single_as_lan=true in site.conf to extend main network through the mesh. It's good to know too.

jerix777 commented Jul 24, 2017

No, it's not the only. I've try to have a special config mode too with these requirements on .
So i've set gw_mode to server in order to set the node as a uplink for others in mesh.
But, after a sysupgrade, gluon reset this value to client breaking down the internet connection for all mesh network...
I've set single_as_lan=true in site.conf to extend main network through the mesh. It's good to know too.

@NeoRaider NeoRaider closed this in a76eaa5 Jul 25, 2017

NeoRaider added a commit that referenced this issue Jul 25, 2017

gluon-mesh-batman-adv: preserve gw_mode on upgrades
When a Gluon node is used to connect to an uplink router/DHCP server (for
example in deployments without VPN tunnels), the gw_mode must be set to
server; this should be preserved on upgrades.

Fixes #1196
@jerix777

This comment has been minimized.

Show comment
Hide comment
@jerix777

jerix777 Jul 29, 2017

Great ! I confirm it works now. Thanks @NeoRaider .

jerix777 commented Jul 29, 2017

Great ! I confirm it works now. Thanks @NeoRaider .

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment