New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Ubiquiti Unifi AC Lite: Problems with eth0 persist #911

Closed
smoe opened this Issue Oct 21, 2016 · 9 comments

Comments

Projects
None yet
6 participants
@smoe
Contributor

smoe commented Oct 21, 2016

We found an issue with the 0.6.2 release concerning the AC Lite that was already mentioned on #689 : the wlan works fine, but the ethernet connection fails. Eth0 is seen by the tools and IP number can be assigned, however tcpdump indicated no traffic on the connection at all. In contrast, the latest Lede-image is running flawlessly.
Could that driver of Lede possibly be backported?

Best regards,

Zafer and Steffen

@rotanid

This comment has been minimized.

Show comment
Hide comment
@rotanid

rotanid Oct 23, 2016

Member

what is the "0.6.2" release?
we need to know which exact gluon version you or your community are using.

Member

rotanid commented Oct 23, 2016

what is the "0.6.2" release?
we need to know which exact gluon version you or your community are using.

@smoe

This comment has been minimized.

Show comment
Hide comment
@smoe

smoe Oct 23, 2016

Contributor

I had checked out tag v2016.2 and the git log's most recent entry says

commit 6964d30ff24eef9fc436e97bc909dc4c5e048ad4
Author: Matthias Schiffer <mschiffer@universe-factory.net>
Date:   Wed Sep 21 20:04:57 2016 +0200

    docs, README: change current release to v2016.2

Many thanks for looking into this!

Contributor

smoe commented Oct 23, 2016

I had checked out tag v2016.2 and the git log's most recent entry says

commit 6964d30ff24eef9fc436e97bc909dc4c5e048ad4
Author: Matthias Schiffer <mschiffer@universe-factory.net>
Date:   Wed Sep 21 20:04:57 2016 +0200

    docs, README: change current release to v2016.2

Many thanks for looking into this!

@NeoRaider

This comment has been minimized.

Show comment
Hide comment
@NeoRaider

NeoRaider Nov 4, 2016

Member

Thanks for the report, please provide the contents of:

  • /etc/config/network
  • /tmp/sysinfo/board_name
  • /tmp/sysinfo/model
Member

NeoRaider commented Nov 4, 2016

Thanks for the report, please provide the contents of:

  • /etc/config/network
  • /tmp/sysinfo/board_name
  • /tmp/sysinfo/model
@Garunda

This comment has been minimized.

Show comment
Hide comment
@Garunda

Garunda Nov 24, 2016

Hello,

here are the desired file-contents:
/tmp/sysinfo/board_name:
unifiac-lite
/tmp/sysinfo/model:
Ubiquiti UniFi-AC-LITE

The file /etc/config/network content is attached.
network.txt

Garunda commented Nov 24, 2016

Hello,

here are the desired file-contents:
/tmp/sysinfo/board_name:
unifiac-lite
/tmp/sysinfo/model:
Ubiquiti UniFi-AC-LITE

The file /etc/config/network content is attached.
network.txt

@SunboX

This comment has been minimized.

Show comment
Hide comment
@SunboX

SunboX Nov 27, 2016

Same for me! 😢 Please find the mentioned files attached.
model.txt
board_name.txt
network.txt

SunboX commented Nov 27, 2016

Same for me! 😢 Please find the mentioned files attached.
model.txt
board_name.txt
network.txt

@ecsv

This comment has been minimized.

Show comment
Hide comment
@ecsv

ecsv Nov 27, 2016

Contributor

I had some problems in the past with the AR803x PHYs. There are patches in LEDE which work around them. For example https://git.lede-project.org/?p=source.git;a=blob;f=target/linux/generic/patches-3.18/735-net-phy-at803x-fix-at8033-sgmii-mode.patch;h=4a8f532aa36f729339e01ebadd6ea3cb292d7ac9;hb=HEAD

There are also other RFCs which I've submitted in the past related to SGMII with this PHY (but with QCA955x as SoC) like https://patchwork.ozlabs.org/patch/606468/ (and other changes in this series). But these aren't in LEDE and thus I would expect to LEDE to be still affected.

EDIT: just gave sunbox a build for testing which only added the sgmii-mode workaround FreifunkVogtland@2bd328c

Contributor

ecsv commented Nov 27, 2016

I had some problems in the past with the AR803x PHYs. There are patches in LEDE which work around them. For example https://git.lede-project.org/?p=source.git;a=blob;f=target/linux/generic/patches-3.18/735-net-phy-at803x-fix-at8033-sgmii-mode.patch;h=4a8f532aa36f729339e01ebadd6ea3cb292d7ac9;hb=HEAD

There are also other RFCs which I've submitted in the past related to SGMII with this PHY (but with QCA955x as SoC) like https://patchwork.ozlabs.org/patch/606468/ (and other changes in this series). But these aren't in LEDE and thus I would expect to LEDE to be still affected.

EDIT: just gave sunbox a build for testing which only added the sgmii-mode workaround FreifunkVogtland@2bd328c

ecsv added a commit to FreifunkVogtland/gluon that referenced this issue Nov 28, 2016

kernel: add at803x workaround for sgmii mode
Some (possibly broken) bootloaders incorrectly initialize the at8033 phy.
This breaks auto-negotation on these SGMII devices. The mode has therefore
to be set back in to a valid configuration by Linux.

Fixes freifunk-gluon#911

ecsv added a commit to FreifunkVogtland/gluon that referenced this issue Nov 28, 2016

kernel: add at803x workaround for sgmii mode
Some (possibly broken) bootloaders incorrectly initialize the at8033 phy.
This breaks auto-negotation on these SGMII devices. The mode has therefore
to be set back in to a valid configuration by Linux.

Fixes freifunk-gluon#911

ecsv added a commit to FreifunkVogtland/gluon that referenced this issue Nov 28, 2016

kernel: add at803x workaround for sgmii mode
Some (possibly broken) bootloaders incorrectly initialize the at8033 phy.
This breaks auto-negotation on these SGMII devices. The mode has therefore
to be set back in to a valid configuration by Linux.

Fixes freifunk-gluon#911
@SunboX

This comment has been minimized.

Show comment
Hide comment
@SunboX

SunboX Nov 28, 2016

The fix was applied to my router by @ecsv (http://vogtland.freifunk.net/map/#!v:m;n:802aa848b87c)

Uplink seems to be stable by now and the Config-Mode works also using DHCP.

SunboX commented Nov 28, 2016

The fix was applied to my router by @ecsv (http://vogtland.freifunk.net/map/#!v:m;n:802aa848b87c)

Uplink seems to be stable by now and the Config-Mode works also using DHCP.

NeoRaider added a commit that referenced this issue Nov 29, 2016

kernel: add at803x workaround for sgmii mode (#949)
Some (possibly broken) bootloaders incorrectly initialize the at8033 phy.
This breaks auto-negotation on these SGMII devices. The mode has therefore
to be set back in to a valid configuration by Linux.

Fixes #911

NeoRaider added a commit that referenced this issue Nov 29, 2016

kernel: add at803x workaround for sgmii mode (#950)
Some (possibly broken) bootloaders incorrectly initialize the at8033 phy.
This breaks auto-negotation on these SGMII devices. The mode has therefore
to be set back in to a valid configuration by Linux.

Fixes #911
@smoe

This comment has been minimized.

Show comment
Hide comment
@smoe

smoe Dec 29, 2016

Contributor

Heya @NeoRaider,
These changes appear not made it to the 0.6.2.2 release tag while @Garunda's experimeal build just works smoothly. Since it is not so straight forward to reflash the device without Ethernet access, please kindly consider to forward those Ubiquity AC Lite changes to the next release.
Cheers,
Steffen

Contributor

smoe commented Dec 29, 2016

Heya @NeoRaider,
These changes appear not made it to the 0.6.2.2 release tag while @Garunda's experimeal build just works smoothly. Since it is not so straight forward to reflash the device without Ethernet access, please kindly consider to forward those Ubiquity AC Lite changes to the next release.
Cheers,
Steffen

@NeoRaider

This comment has been minimized.

Show comment
Hide comment
@NeoRaider

NeoRaider Dec 30, 2016

Member

@smoe, the changes are in v2016.2.x; make sure you always make update and make clean after pulling.

Member

NeoRaider commented Dec 30, 2016

@smoe, the changes are in v2016.2.x; make sure you always make update and make clean after pulling.

ecsv added a commit to FreifunkVogtland/gluon that referenced this issue Jun 9, 2017

kernel: add at803x workaround for sgmii mode
Some (possibly broken) bootloaders incorrectly initialize the at8033 phy.
This breaks auto-negotation on these SGMII devices. The mode has therefore
to be set back in to a valid configuration by Linux.

Fixes freifunk-gluon#911

ecsv added a commit to FreifunkVogtland/gluon that referenced this issue Jun 9, 2017

kernel: add at803x workaround for sgmii mode (freifunk-gluon#950)
Some (possibly broken) bootloaders incorrectly initialize the at8033 phy.
This breaks auto-negotation on these SGMII devices. The mode has therefore
to be set back in to a valid configuration by Linux.

Fixes freifunk-gluon#911
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment