Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

w3.org-link instead of content #7013

Open
BinkaDroid opened this Issue Apr 14, 2019 · 7 comments

Comments

Projects
None yet
4 participants
@BinkaDroid
Copy link

BinkaDroid commented Apr 14, 2019

Expected behavior

content/ message

Actual behavior

A link like https://www.w3.org/ns/activitystreams#Announce; correct content appears some time later but additionally to the strange announce-post

Steps to reproduce the problem

no steps, started happening a few days ago, other people on other friendica servers having the same problem

Friendica version you encountered the problem

2019.03

Example Screenshot (left source, right what is displayed in my friendica)
Screenshot 2019-04-14 at 22 21 37

@tobiasd

This comment has been minimized.

Copy link
Collaborator

tobiasd commented Apr 15, 2019

@BinkaDroid

This comment has been minimized.

Copy link
Author

BinkaDroid commented Apr 15, 2019

To understand it correctly: this happens, when an original message is delivered from a server running any dev-version of friendica?

I'm asking, because in this example, two comments via diaspora still aren't showing up even 3 & 4 hours later:
Screenshot_20190415-093925

@annando

This comment has been minimized.

Copy link
Collaborator

annando commented Apr 15, 2019

You see this "2 people reshared this" on the left side. This is what the "Announce" message is for.

@BinkaDroid

This comment has been minimized.

Copy link
Author

BinkaDroid commented Apr 15, 2019

Awhhhhh, sorry, I'm a little bit slow sometimes... Now I understand it (haven't had another look at the original posting).

@loma-one

This comment has been minimized.

Copy link

loma-one commented Apr 15, 2019

no steps, started happening a few days ago, other people on aother friendica servers having the same problem
This is a glitch in the Matrix ;-) The current development version of Friendica has a new way to display when a posting was reshared. This is essentially what the message displayed with the link is, the announcement that somebody reshared the posting. So, not a bug, but the dawning of a new feature / era in Friendica 2019.06.

But this is what is displayed on the Stable Friendica 2019.03. This is rather irritating.

@tobiasd

This comment has been minimized.

Copy link
Collaborator

tobiasd commented Apr 15, 2019

@BinkaDroid

This comment has been minimized.

Copy link
Author

BinkaDroid commented Apr 15, 2019

As a workaround, I changed the CSS for the default theme in my friendica installation:

a[href="https://www.w3.org/ns/activitystreams#Announce"]:before {
	color: #999;
	font-style: italic;
	content: "shared this/ hat diesen Beitrag geteilt" !important;
}
a[href="https://www.w3.org/ns/activitystreams#Announce"] {
	color:transparent!important;
}

so it looks like this:
Anmerkung 2019-04-15 215223

If you cannot fiddle around in your friendica-installation, you can use the extension "stylus" (NOT: stylish) - available for Vivaldi, Chrome, Firefox etc. & and use this custom CSS to make this glitch less annoying ;-)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.